Showing results for 
Search instead for 
Did you mean: 

PTC for Quest v.39 Megathread

Community Manager
Community Manager

The Public Test Channel (PTC) for Quest and Quest 2 v.39 is starting to roll out today. Let's use this thread for collecting feedback on it. Share your impressions and let us know if you see any issues. Please make sure to also send in bug reports along with posting here if you notice anything wrong.


When sharing feedback, try to include as much detail as possible to help the team investigate.

Help others find great discussions and answers by adding kudos and marking solutions to your questions.
198 REPLIES 198

I find that highly unlikely but it would be great if @Ryanality could address this for many of us.

Nothing would surprise me at this point.

Are you still on PTC branch for updates? Can you update on this thread if there is any hotfix that restores higher refresh rate functionality?


I got off the PTC and last I checked it was full, so I'll update if it gets fixed on next regular branch release.

It looks like Mountain Study is back up with the new Desk Guardian design and I also noticed that the new Desk Guardian design was in the Studio environment as well. 👍

Unfortunately, still nothing on the higher refresh rates. The 120 hz experimental setting is still missing. I even tried a test to see if I could lower it to 60 hz to match a test media file and it didn't work. It's just locked at 72 hz. The desktop app only shows 72 hz as the one setting under Graphics Preferences.

Level 4

Most of PTC Users wait for a official Update and then, they are not longer a PTC User.

but hat´s no problem, because PTC is full.


Meanwhile Virtual Desktop is better. 😉


I was having the smae problem as some of you ( no guardian appears, guardian music plays,can only see hands and places to teleport to and that is it )

I tried doing a factory reset, and it came back to me, only for me to turn it off later and turn it on back to the same loop.

I tried doing what this guy suggested ( follow at your own risk ) and I tried installing v38 ( I believe I was on version 39 ) and after the update finished, it gave me a message that I was on a newer firmware already and it didn't go through ( that was after I had done a factory reset )

And I reconfigured everything, did a power off and on just to see If I would get the same problem that I ran into from before ( did a factory reset, configured everything, turned off headset and on  just to be stuck at the beggining again) and this time it just worked.

It might be the fact that I have set the guardian after the factory reset when I still had control ( first boot, drawing the floor and **bleep** ) but after the power off and on cycle, it is still working.

I guess we can't disable the guardian at least for now ( I hate this **bleep** ) or otherwise it will try to enable it for you after the boot but something is wrong with it at the new v39 firmware.

My version now is  system version 26242800497100000

Hopefully it can help someone out there who might run across this error.

C ya all and if it happens again I will update you all in here.



Level 2

Perhaps due to the version upgrade, the home screen is dark except for the controller being displayed, and I can no longer launch or operate apps.
I searched for people with the same symptoms on twitter, and it seems that there are a certain number of them. Also, there is some information that it seems to be cured by restoring the device to the factory default state, but when it is restored from sleep, it becomes pitch black again. Currently, the only solution seems to be to make it possible to launch the Quest application from the smartphone application.

Yeah, it is weird. So far my headset is still working, but I am definitely afraid of turning the guardian off and getting stuck in the loop again.

Meanwhile, this was the response the official support from meta gave me:



Hello Rodrigo,
I hope you're safe and sound.
Thank you so much for getting us back at Oculus Support.
I appreciate your effort in trying to do some troubleshooting steps provided. You're awesome!
To begin with, I would like to thank you for your utmost cooperation while working on this with us. We value customer's satisfaction and will be more than happy to assist you in sorting this out.
While I look into this further for you, I would like to collect some additional information:

  • Full name
  • Shipping address
  • Phone number
  • Preferred email address to receive labels
  • Oculus username and/or email address associated with your account
  • Headset serial number: which is located under the left strap and starts with "1WMHH"
  • Unit serial number, which can be located on the bottom of the box and starts with "1WMVR"
  • Retail receipt or invoice including item, retailer, price, and date -OR- Oculus order number

We'll be looking forward to you response  at your most convenient time .
Have a great day ahead
Kind regards,



Why would I need to provide all this info for apparently no reason at all?

Such a weird response ( maybe not that weird considering facebook/meta ) but I definitely won't be giving my info away like this because it makes no sense, AFAIK in helping me with my problem and everyone else's problem.

If I get a new reply or something I will update you all.

C ya.

This is what I was getting ( I am pretty sure it is the same for everybody else with this problem )

 If you need to factory reset, just try to make sure you don't disable it after the initial config ( which is what I do most of the time )

It really seems like they are forcing the guardian settings at the beginning and it doesn't know what to do when it is disabled.