Showing results for 
Search instead for 
Did you mean: 

PTC v43 Release Megathread

Community Manager
Community Manager

The Public Test Channel (PTC) for Quest and Quest 2 v43 is starting to roll out. Let's use this thread for collecting feedback on it. Share your impressions and let us know if you see any issues. Please make sure to also send in bug reports along with posting here if you notice anything going wrong.


Thanks to everyone testing out PTC and sharing your feedback! We appreciate your help testing out the core functionality of software as we develop!

Help others find great discussions and answers by adding kudos and marking solutions to your questions.
137 REPLIES 137

Level 3

Hi. Meta Quest 2 via Airlink has really strange issues for me on the latest BETA (Quest2 firmware version As soon as i updated and used Airlink which was working fine an hour before the update, I have unbearable double flinching image in Airlink when i move my head especially vertically. I cannot explain it better, but my eyes hurts in 2 minutes. Is like the image flinches quickly then stabilizes then again etc every time i move my head.
What I tried: lowering the resolution and the airlink connection to under 50 mbps, reinstalling Oculus software on PC, restarting PC/Quest 2 multiple times, restarted My 5ghz Asus router.. I should mention I had zero issues before the latest Q2 beta update, and I was using it fine 1 hour before the update. But now it destroys my eyes in max 2 minutes, unbearable. Oculus PC app is still on latest beta (Oculus App Version As of now, I consider using Airlink a big NO, since it kinda ruins my eyes. I also sent a feedback thingie.

I join your post. Exactly the same problem I had right after 43 updates, only I used Link (cable)

i have the same problem you described but with cable link. I tried to remove the PTC on the pc and reinstall the previous stable version but the problem persists. This problem started after updating the software on the headset to V43. On the pc the oculus software version is

Level 4

Same issue for me. V43 both on the Quest 2 and on the PC App.

Using AirLink the imagine flickers when I move the head.

Level 4

Same issue with Quest PTC V43 on Air/Link (Wired as well) with flickering (reprojections?) with any head movement.  Seems like it's almost a forced ASW mode or something. It happens in the oculus dashboard right upon connecting via Air/Link.  Tried resetting Air/Link Settings to default via OculusDebug tool along with a slew of other things that didn't work. To note what others have said everything was working fine before this PTC Update.  The Issue is more pronounced on higher refresh rates eg 120/90/80 and less noticeable at 72hz in my case.  I submitted a bug report as well.

10900K | RTX 3090

Level 3

Thanks guys for confirming this, at least I know that is not on my side. I wish we had some changelog on what is touched in PTC, because that's the point right to report on stuff, but if you don't know what is changed/updated and what to test is kinda hard. I think on my next Q2 update if everything works I'll disable the PTC since it can break critical stuff and no way to rollback. Also I can't report stuff that it may be my fault ( Airlink for example can go wrong for so many reasons, user related or not) , if I don't know that that part was touched by the update.

Level 3

I have disabled the PTC, now I cannot re-enter the channel because the maximum number of participants has been reached. Is there no way to go back to the previous version? 

Sadly I don't think You can go back. As per this thread: 

"Currently, Oculus Quest software does not have the ability to roll back to a previous software version release. If you remove yourself from Quest PTC, your device will remain on the Quest PTC software version until the next Oculus public software version release."

Also there it mentions that PTC will only be available for a limited number of participants, so if u quit and  if the toggle is disabled, Quest PTC is currently full and not available to join. 

This means that You are basically stuck with the current installed version until a PUBLIC version is available for upgrade (that can be 2-3 weeks or maybe a month) . This is bad that you are stuck in the current Link-botched state. Maybe You can get your PTC spot back, check there often if one becomes available, cause the next PTC update that hopefully resolves this bug should  happen sooner than the public.

in the oculus software for windows if i disable the PTC it goes back to the previous version. I thought it was the same on the Quest. I had missed this step that does not come back. 😞 Fortunately I also have the Quest 1 at least I can use it to connect it to the PC, waiting for the public update