Showing results for 
Search instead for 
Did you mean: 
Community Manager
Community Manager

Thanks everyone for all your feedback on our previous builds, we several bugs were identified in the last PTC and the solutions for some have shipped, while others are on the way!

The Public Test Channel (PTC) for Quest v57 is starting to roll out for Meta Quest Pro and Meta Quest 2 soon. 

Our new process from v56 worked great to create specific threads for each issue that's happening so let's do that again!

If you're seeing an issue or bug after updating to PTC v57 jump on over to our Get Help board and search for any existing thread, if you don't find one, make a new thread. Please add the tag PTC v57 to the thread and in the title. This way everyone can look for just PTC v57 issues too.

It's best if you can post each bug you spot in its own thread, to keep track of individual issues separately.

Share your impressions and let us know if you see any issues. Please make sure to also send in bug reports along with posting here if you notice anything going wrong. 

We know it's tough when you run into a problem on a PTC build and want to thank you all again for testing out PTC and sharing your feedback! This feedback is extremely helpful to our engineering teams. We appreciate your interest and persistence in testing out the core functionality of software as we develop!


I've seen a couple of Quest users report problems with link and I've replied the following to them.  Maybe this will be useful for others.

OK, while I also normally use Air Link I switched of to my usb3 Link cable (Kuject powered Link cable I bought from Amazon +1.5 years ago for my Q2) and all worked very well with both my Q2 and QPro at 650mbps bitrate. I tried a number of Rift and Steam games and these all worked great. Also tried the flight sim msfs and this also worked great. I actually forgot how distant objects look quite a bit better with Link.

I am on PTC V57 on both headsets (version # and on the oculus desktop app public beta (version # Maybe check both those version numbers and see if they are the same as your final V57. You may want to opt into the oculus desktop app public beta and give that a go (settings/beta tab). BTW, I've been on the PTC's on both headsets and the oculus desktop app since V51 and haven't had any problems.

While I can't say for sure if non-beta versions work or not, I'd be kinda surprised if they didn't. Maybe someone with v57 final issues tries just opting into the oculus desktop app public beta they can report if this fixes things with Link or not. If not, then they should file a bug report and also lodge a support ticket including their log files so Meta support can identify and fix this. Simply ranting about it without suppling details isn't very useful imho.


@TomCgcmfc   Good note. I pulled out my old link cable several weeks ago testing some steam version audio trip lag issues for the devs in comparison to using air link alone (not virtual desktop). It did improve the connection. Since then there have been a couple quest ptc/final firmware updates and I do think the airlink connection has improved. I can tell a difference in AT and when playing high graphics/load games like After the Fall and Kayak VR. Good thing too because while the cable still works, possible trip hazard is a lot greater. 😄

Sidenotes - Q Pro controller wake up/connection seems to be faster since the last firmware release too. And, it is nice to be able to turn that mirror off (Q2 peeps can do it too) in the personalization setting section.

Heroic Explorer

Is there an easy way to cut-n-paste the version/build info from the headset to browser posts like this? The mobile and PC apps don't show the headset version info. There's no way to select and copy the version info from the system settings screen to a clipboard. Writing down by hand four ~15-20 character numbers down by hand is especially tedious if you have poor eyesight and have corrective lenses in the headset and need to put glasses on after taken of the headset in order to see what you are writing. The best I have come up with is to take a screenshot of the settings page, transfer the image to my PC. Then print out the image and transcribe the numbers by hand. Again, very tedious.

Yes, I checked the phone app, PTC not enabled. So where do I report bugs since there is no v57 release thread as of yet?