Showing results for 
Search instead for 
Did you mean: 

Head avatars not loading or white default heads [Solved]


I'm trying to launch the AvatarGallery scene in Unity 2019.4.14f1 with the oculus integration version 23.1.0 and the OVRPlugin version 1.55.1 (same problem with other oculus integration and OVRPlugin versions)

When I run the APK in Quest whit CombinedMesh = true, heads doesn't load and I have the following error:
Hair Mismatching Resolutions: DiffuseTextures 1024 (ID: 1708191947127680157) vs 2048 (ID: 0) Ensure you are using ASTC texture compression on Android or turn off CombineMeshes
at OvrAvatarMaterialManager.ValidateTextures (ovrAvatarPBSMaterialState[] materialStates) [0x00000] in <00000000000000000000000000000000>:0
at OvrAvatarSkinnedMeshPBSV2RenderComponent.Initialize (System.IntPtr renderPart, ovrAvatarRenderPart_SkinnedMeshRenderPBS_V2 skinnedMeshRender, OvrAvatarMaterialManager materialManager, System.Int32 thirdPersonLayer, System.Int32 firstPersonLayer, System.Boolean combinedMesh, ovrAvatarAssetLevelOfDetail lod, System.Boolean assignExpressiveParams, OvrAvatar avatar, System.Boolean isControllerModel) [0x00000] in <00000000000000000000000000000000>:0
at OvrAvatar.AddSkinnedMeshRenderPBSV2Component (System.IntPtr renderPart, UnityEngine.GameObject go, ovrAvatarRenderPart_SkinnedMeshRenderPBS_V2 skinnedMeshRenderPBSV2, System.Boolean isBodyPartZero, System.Boolean isControllerModel) [
If I change CombinedMesh to false, then heads load but all of them are white:

And I have a spatializer error, but I don't think that is the problem here:
Unable to find AudioPluginOculusSpatializer
DllNotFoundException: Unable to load DLL 'AudioPluginOculusSpatializer': The specified module could not be found.
at ONSPAudioSource.OSP_SetGlobalVoiceLimit (System.Int32 VoiceLimit) [0x00000] in <00000000000000000000000000000000>:0
(Filename: currently not available on il2cpp Line: -1)
I have ASTC, OpenGLES3, and the ids in the settings.

I've tried several things and I don't know what else do so I apreciate any kind of help.

Thank you in advance and hace a nice day.


Finally solved! 

It was a silly mistake by our side. We forgot to activate the Avatars service in the "Data Use Checkup" in our app.

Also remember to use a rift app id to launch tests in the editor.


I have done all of this and they are still not loading. Does the app have to actually be published, or should it work as long as I have a working app lab ID? I have avatars activated in AppLab, It is passing the entitlement check and it is fetching/setting the avatar ID before I enable the LocalAvatar object. I don't know what the problem could be.