cancel
Showing results for 
Search instead for 
Did you mean: 

From one moment to the other, Meta Quest Developers Hub no longer finds Quest 2

PenProd
Honored Guest

As the title says.

I've been developing a game for the Quest 2 for over a year now and since yesterday, MQDH suddenly stopped finding my Quest 2. Literally from one moment to the other. It just lost connection and it never found the Quest again. If I start the Oculus program on my PC, the Quest is detected just fine.

I have tried different cables, restarted y PC and the Quest a few times - nothing helps. I wanted to check if developer's mode is still on, so I tried linking the Quest with my Oculus app on my phone. But even more weirdness happens there. The app tells me it has found a Quest 2 and asks me to enter the 5 digit code. I enter the code I find under System -> Info, then after a while it tells me it can't find the headset. The thing is, if I start the process (on my phone) to link the Quest, it tells me it has found a Quest 2 - even when the headset is off.

Now the Quest 2 and the Meta Quest Developer's Hub are not on the same account - but they never were. So that's not (part of) the problem.

So what is causing MQDH not finding the Quest 2 anymore and how can I solve this?

 

2 REPLIES 2

draconisinterstellar
Honored Guest

I also just started hitting this a couple days ago. Developer Hub no longer detects when the Quest 3 is connected. Tried the usual, resetting accounts, switching cables, etc.

PenProd
Honored Guest

I ended up factory resetting the Quest 2 because no matter what I tried, MQDH did not detect it. After factory resetting, it immediately detected the Q2.