cancel
Showing results for 
Search instead for 
Did you mean: 

GetLoggedInUser returns Oculus ID 0 with v59 update

stevenlinton
Explorer

I have my build on three Quest 3 devices.

Two are running: 59.0.0.163.706.533208642

The other is running: 57.0.0.297.669.526237896

All devices are using the same login account.

When running GetLoggedInUser it returns the correct Oculus ID on v57, and Oculus Id=0 on v59.

---- 

I have confirmed this by updating the v57 device to v59 and now the Oculus Id=0 using the same build and account.

Too the best of my knowledge all required permissions are provided. 

1 ACCEPTED SOLUTION

Accepted Solutions

jtriveri
Adventurer

I got it working by doing the following:

  • uploading a build of our own app to meta in our registered app’s private release channel on the developer dashboard
  • adding my own account as a test user to this registered app on the developer dashboard
  • running Entitlement Check before obtaining user ID

View solution in original post

5 REPLIES 5

jtriveri
Adventurer

seeing same behavior. We have dozens of headsets that are split between v59 and v57.
All on v59 returned 0, while all on v57 retrieved the ID correctly.

jtriveri
Adventurer

I got it working by doing the following:

  • uploading a build of our own app to meta in our registered app’s private release channel on the developer dashboard
  • adding my own account as a test user to this registered app on the developer dashboard
  • running Entitlement Check before obtaining user ID

I did all this too and it's still not working for me. Did you upload it to the alpha release channel? Also is there a difference between a "user" and a "test user"? I don't see test user available as an option anywhere on the app manager. I dunno what to do

IMG_2572.jpeg

 sorry, I meant inviting your own account to test the app through the release channel. You may have done this already but just in case the option appears in app > Distribution > Release Channels >  number in ‘Users’ column for given release channel

Ok, I saw you did add yourself to the test channel in your other post.
Are you running the entitlement check when your app launches? This is the one other change I made to my own app before the platform api started working.

https://developer.oculus.com/documentation/unity/ps-entitlement-check/