cancel
Showing results for 
Search instead for 
Did you mean: 

Purchase Failed - This item isn't set for purchases yet.

SuffescomOcuLus
Honored Guest

Hi,

We recently released our "SetVr Xl-Unleashed" application in the Meta App lab.
We are selling this application at 19.99$.
When our users from the US region tried to purchase this application, their Purchase failed. They tried 3-4 times but every time, the same result.  Please see the attached images for reference.

App link -https://www.meta.com/experiences/7497491080333401/?require_login=true&utm_source=developer.oculus.com&utm_me...

image_2024_06_12T06_53_54_824Z (1).png

2 REPLIES 2

TheLegend27
Meta Quest Support
Meta Quest Support

Hey @SuffescomOcuLus! Just took a look at the app trailer, it looks like a lot of fun! I tried having a look through the developer docs to see if something might be able to point you in the right direction, but I couldn't find much for this one specifically.

I recommend reaching out to our developer support team to see if they're able to help out:

  1. Go to the Developer Support Center and click on the "Sign In" link in the upper right corner.
  2. Sign into your Developer Account.
  3. Then use the Contact Us form to create a Support request.

Make sure you have a verified developer account, otherwise you may be redirected to the "Not Registered" page.

Hope this helps!

I already posted the same issue over there(link -https://oculusdevelopers.zendesk.com/hc/en-us/requests/55088 ), but their support team couldn't find any problem. According to them, users should able to purchase without any problem. That's why I posted here after that, hoping to get some solution.