Showing results for 
Search instead for 
Did you mean: 

can not "Create Organization"

Level 2



if i follow your process to and try to create Organiaztion it shows "Unable to Load Content Check your URL and try again."

if i try to "Verify Your Oculus Developer Account", i have to add Credit Card set up two-factor authentication. I have tried both without success. The Credit Card Information wont save and the two-factor authentication is set up but is not recognized by this site.


Any help would be appreciated,

best regards



hey I think is the internet.. resert in modem 

Hi raymondthejester
I had the same issue with non incoming SMS. I believe there is a bug on the website which doesn't select properly the country, so it probably sends the sms to another country.

It worked for me when i selected my country, then opened the country-dropdown and selected my country  for the 2nd time.

Where do I go to do select my country? I can't find that and the country-dropdown menu anywhere.

Level 2


I hope it will work for You as it did for me. I was able to do it via Firefox browser.

That also didn't work, is there a certain way I have to type my number? Like does it need spaces or dashes?