Showing results for 
Search instead for 
Did you mean: 

can not "Create Organization"

Honored Guest



if i follow your process to and try to create Organiaztion it shows "Unable to Load Content Check your URL and try again."

if i try to "Verify Your Oculus Developer Account", i have to add Credit Card set up two-factor authentication. I have tried both without success. The Credit Card Information wont save and the two-factor authentication is set up but is not recognized by this site.


Any help would be appreciated,

best regards



Honored Guest

Found a solution to my problem.... 

For the two-factor authentication you have to use the phone authentication instead of the app authentication... Now it works


This works for me . Thanks


I type in my phone number but it never sends the code. I've tried it like about, a hundred actual times.

Honored Guest

facebook sends me сhinese characters via SMS instead of 6 numbers, can't verify phone. If I add app authentication nothing happens


Hey there @Kerboch, are you using a VPN by any chance? What type of phone are you using and have you verified the Meta application as well as your phone are fully updated?

I'm not using vpn, and i suppose it should not matter what phone to use, as any phone can resive SMS, and i should have god SMS with numbers even on nokia 3310, unfortunatly i haven't seen numbers amon chinese hieroglyphs. But all in all I have succeed. I'm from Ukrain, so I chose russian language on site before trying to create organization. During about 5 tryes I've got messages with chinese hieroglyphs from "FACEBOOK" on my +380.... phone number, than I loged out, loged in and continued in english and something has realy changed. First of all I stopped receiving messages at all, and on the 4th or 5th try I finaly recived message in russia language, and now sender was "Facebook", and message contained 6 numbers.

I can't use my phone number as I am already using it for my personal account. I have a second account for a shared device my organization has purchased but I do not have another phone number that can receive text messages so I cannot do the phone authentication.

I have the same problem I just login out

Hey we in same beat