cancel
Showing results for 
Search instead for 
Did you mean: 

After crash pc does not find my Meta Quest 3 anymore

Labi25
Honored Guest

Hey, today i got my Meta Quest 3 and wanted to play via Quest Link. I immediately found my pc after setting everything up and wanted to play.
Sadly then i did not have anything displayed anymore on my Quest and i had to shut it down.

Since then i can not connect to my PC anymore, it is not being found via air-link.

I already tried repairing my installation, un-pairing my quest from the PC and making a factory reset for the quest, but sadly nothing worked. Are there any more tips to solve this issue?

1 ACCEPTED SOLUTION

Accepted Solutions

Labi25
Honored Guest

Restarting my router fixed it, thanks!

View solution in original post

1 REPLY 1

Labi25
Honored Guest

Restarting my router fixed it, thanks!

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?