Showing results for 
Search instead for 
Did you mean: 

After many many attempts I MADE IT WORK AGAIN. HERE'S HOW

Level 3

For Gear VR I am using a Samsung S6 edge. I basically used THIS GUIDE and a bit of common sense and here's the dumbproof guide with as many details as I could possibly recall for you😘


These are the TOOLS that I used based on my phone's resolution, Architecture and Android version. You might need to tweak the variants you're gonna get from APKmirror website to suit your model


1. Install Smart Switch because we're going to play around with hard resets.

Before I backup everything I go to Smart Switch preferences in Windows and check the option "Latest Software Pre-Download"

2. Backup all you think you might need make so  you don't have to cry that you have to set everything up again, except any apps ("Latest Software Predownload" option will still get other system apps and stuff and I have no say whether I can choose to backup those or not) - just make sure you leave out all the Facebook, Gear VR related apps and you're good.

3. Hard reset your phone

4. After that's done and you're finally back first thing you do, go to Play Store and disable auto-updates. Those will still happen, but more on this later.

5.Install Meta App Installer, Meta App Manager, and Meta Services.

6. Update those manually, along with Facebook.

7. After this is done, get some Package Manager such as APK Installer so you're able to uninstall multiple apps at the same time and get rid of everything Oculus and Gear VR related and leave only Gear VR SetupWizard only if the installed version is LOWER than 3.0.21 - Otherwise you won't pe able to "upgrade" the app to a lower version and it will say the package is corrupted. Be careful: Meta App Manager is doing its thing and those apps will slowly creep back into your system. You don't want that.

8. The moment you got rid of the apps, quickly install Gear VR SetupWizard and Samsung VR.


One more quick look in the App Manager just before the setup process to make sure Gear VR SetupWizard hasn't magically reappered or got updated to a different version (it happened to me, I had start from scratch)


9. Insert phone into headset to get that setup thing going, as version 3.0.21 of the app seems to install the working version of the rest of the packages and services, or at least the right combo.

10. Copy the MVRI.txt and VR360Video_3_00_0_EULA_agreed.txt from com.samsungvr.packagenamecrapthingie.apk/files/ folder to Internal Storage/Android/Data/ folder. Be sure to delete the other files, if there are any - There should be a VR360Video_2_00_0_EULA_agreed.txt file in there. This will eliminate the need for you to accept the EULA and supposedly that's what makes it work. You are using precisely this version of Gear VR SetupWizard, because allegedly is the latest version that doesn't need Internet for setup and it seems to work. It didn't make any sense to me, but as I was advised I did it like a sheep and it just effing worked.

11 After these are installed, open Samsung VR and try to setup the account using your old Oculus account or create a new one with EMAIL, not Facebook. The way I managed to create a new account was and to avoid getting nagged by the new Meta Platform was to go on a laptop, on a browser with cleared cookies and go onto an old website such as this one or do a Google search something related to Gear VR and try to get an Oculus login page and make a new email account from there, which you could later use in Oculus App.

12. It should work now. Welcome back.


credits go to xda-developers crowd.


I hope I was eloquent enough and this helps you. If for some weird reason it didn't, keep at it and you should be back in no time. At the moment I'm terrified to update anything else and don't wanna do anything that'll break it, but it should give you some time until they release some patches and whatnot.  Peace.


Level 4

Great job but WAY too much effort for me.


After 7 days I got it to work but don’t have games on my headset 

Level 3

I'm really sorry for everyone who didn't fix it.A quick update: since I managed to fix it, I managed to be up-to-date with all apps, except Meta Quest app, which I don't intend on going back to too soon and it would seem that it works pretty good with the good old Oculus. There was a strange bug for some time after I managed to back inside, as I couldn't access the library. At all, but somehow it all got fixed and I'm starting to hink now that this fix wasn't just on me, as I noticed some subtle changes in some profile menu of Meta profile and Oculus one and I think they've been slowly undoing their **bleep**ups and hopefully everyone will be able to go back to it.


@GOLFERAAsoon it will work by itself.

I  actually really don’t understand how I got Oculus to work again so I’ve been thinking about what I did.  First I  only use Oculus for a flight simulator so I don’t have games on my headset.


After setting up my  Meta  account I was prompted to enter and 8 digit/character code but I ended up getting locked out.  After days of trying what they suggested thing got worse.  But you still get prompted to click on Facebook to access  Oculus so I checked settings on both.


What I discovered is I had a different email for Meta than Facebook.  Now they both have the same email address and once I did a factory reset, everything seems to be working.


Probably just lucky……..