Showing results for 
Search instead for 
Did you mean: 

After trying everything, the Rift S microphone still turns robotic every few seconds.

Level 2

When I first received my Rift S, I had a LOT of problems, including the robotic voice, the headset just randomly losing tracking, and the headset sometimes not even connecting at all. I was determined to get it working so I read many websites and forums and tried everything, eventually giving up and purchasing a powered USB hub since I heard that others had success with it. Unfortunately this didn't work for me. I returned this, and instead purchased a USB 3 card to go into my motherboard's PCI-E slot. This actually fixed all of my problems for a time. I like to play VR with friends, we like to sit in a discord call and talk while we play. When the headset works, it works great, a perfect experience. After maybe a day, the microphone suddenly starts being robotic again. It happens every 20 seconds or so and lasts around the same time. This is currently the only problem that I am experiencing. I've tried changing my default audio device in Windows, unchecking the box to allow apps to take control, repairing Oculus software, switching USB ports, unplugging all other audio devices, basically everything you can think of. I was considering just returning it and getting a Quest 2 instead but figuring out and waiting for deliveries and refunds of these items now means that I've owned the headset for more than the 30 day refund period. Any help I could get with this would be greatly appreciated.