Showing results for 
Search instead for 
Did you mean: 

Air Link Stopped working after V.56 Update


I use Air Link regularly to play PCVR games using my Quest 2. I noticed that I could no longer connect to my PC using Air Link after my Quest 2 updated to version 56. My VR PC shows up in the Quest 2 headset as "Not Connected" and will display an error message saying "Can't Connect to Username::PCName - Please try again. If you're still having trouble, try restarting your headset, or restart the Quest PC app In Settings > Beta."

I have followed the Support suggestions to enter Safe Mode and use Control Panel to remove the Oculus PC app along with deleting the various directories and files used by the Oculus app. The PC was then rebooted and the Oculus app was downloaded and installed fresh. I then tried to "Add Device" from the PC app using Air Link without success. I could add my Quest 2 using the USB cable though. I have done this twice now and even used the Registry Editor to remove all the Oculus keys before reinstalling the PC app. Still, the problem remains.

My system specs are as follows:

Processor 12th Gen Intel(R) Core(TM) i7-12700K   3.60 GHz
Installed RAM 16.0 GB (15.7 GB usable)
OS Windows 11 Pro (22H2)
Geforce Driver 537.13 (08/22/2023)
Ethernet cable direct to router.
Oculus App
Quest 2
System Version 506006/0051800150
Runtime Version
OS Version SQ3A 220605.008 A1
Has strong WiFi 6 connection to router.
Thanks in advance for any help you can provide to get my Air Link back working.

Honored Guest

I'm having same issue 

Hey there @OBD and @sigmo354! We hope you're having a wonderful day today! Thank you for reaching out to us with this issue. We definitely know it's never fun to experience issues with PCVR, wo we would love to get that resolved for you. At this time, we would like to give some troubleshooting steps that may fix this issue a try. Please follow these steps in order to prevent any additional issues:

  1. Disconnect the Rift/Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content. You can find steps on how to do so by clicking here.
  4. Reboot into Safe Mode. You can find steps on how to do so by clicking here.
  5. Uninstall the Oculus PC app using the Control Panel. You can find steps on how to do so by clicking here.
  6. Delete all Oculus folders from the following folder:C:\Program Files
  7. Remove any Oculus folders from the following locations:
    1. C:\Users\YourUserProfile\AppData
    2. C:\Users\YourUserProfile\AppData\Local
    3. C:\Users\YourUserProfile\AppData\LocalLow
    4. C:\Users\YourUserProfile\AppData\Roaming
    5. C:\OculusSetup-DownloadCache
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Rift/Link cable and re-test the headset

Once you give these steps a try, please feel free to reach back out to us at any time if the issues persist! Have a great day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there MetaQuestSupport! I hope you're having a great day too. Thank you for replying to my post about the issue I am having with not being able to get Air Link to work since my Meta Quest 2 updated to version 56. You are 100 percent right about it not being fun to lose access to my PCVR games. The troubleshooting steps that you laid out are exactly the steps I followed, twice, before posting here. I see where this advice has worked for some others but unfortunately those steps did not solve the problem for me. Do you have any other suggestions that might get me back to being able to enjoy some PCVR?

Thanks again!


Hey there, @OBD. Thank you for reaching back out and letting us know that you have already done the troubleshooting steps without any luck. We know that something like this is less than ideal, and we would like to provide some steps to help out.


To repair the Oculus PC app:

  1. Go to scroll down to Oculus Rift S, and click Download Software.
  2. Select Repair.
  3. Allow the repair process to run, download, and install.
  4. Launch the Oculus PC app.
    • If Windows asks you if you’re sure you want to open this file, click yes.
    • If Windows Defender prompts Windows protected your PC, click More Info and then click Run anyway.
    • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
    • Please remember to re-enable your antivirus software once you've completed the repair.

Let us know how this goes, and if you have any questions, please don't hesitate to ask.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello, @OBD! Just checking in to see if you are still needing assistance with your Airlink. If so, please do reach back out to us at your earliest convenience. Thank you!


If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello @MetaQuestSupport! Thank you for reaching out. Before the end of the week, I will attempt to repair the Oculus PC app following the steps you outlined your post. I will be sure to post the results once completed and hopefully it will be good news.



Hi there, @OBD. Thank you for your reply and letting us know that you will go ahead and do the troubleshooting later on. When you do, just let us know how it went. We are looking forward to your reply.


If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


I also had the same issue occur right after installing v56. I tried reboots of the Quest2 and the PC but it cannot see the device at all. Windows USB device manager can see the Quest device fine so it's not a connectivity issue and seems clearly related to the v56 update.

Hello @MetaQuestSupport! I hope you're having a fantastic day. I followed the steps as you outlined to repair the Oculus PC app. The repair process generated no errors. I am sad to say that the problem remains and I am still unable to connect my Meta Quest 2 to my PC using AirLink.