Showing results for 
Search instead for 
Did you mean: 

Air Link cannot find PC

Honored Guest

Imma keep this as short as possible.
I got a new 5GHz / 2.4GHz router so I could use Oculus Air Link without it stuttering every five seconds (my previous router only had 2.4GHz). When I try connect to my PC it just says "searching for device" but cannot find the PC. I have been troubleshooting and looking at forums and reddit posts for the past few days but none of the advices I have found so far have helped me. I found out that if both devices [the PC(in this case an old laptop I found) and the Quest 2] are connected to Wi-Fi, instead of the PC being connected to Ethernet, Air Link can find the Device and it works without problem. But my PC doesn't have a Wi-Fi adapter, and even if it did I do not want to use Wi-Fi on my PC for Air Link.
Here's a list of everything I have done to try and fix this issue:

  • Turn both devices off and on again
  • Turn Air Link on both devices off and on again
  • Uninstall the Quest app and install it again
  • Turn off my Firewall
  • Port forward the port 5669
  • Change some stuff in my registry
  • scream at my pc for 10 minutes straight
  • Disable DNS Proxy in my router's settings (Not exactly sure what it does but I thought maybe that could be the reason. It wasn't)
  • Turn off all anti-virus programs (A.K.A. Windows Defender)
  • Change from 80MHz to 20/40MHz in my router's settings (like I already said, the problem isn't the wi-fi but the ethernet)

I'm really desperate for help. My Oculus Link cable also started to act up yesterday and replacing it would cost too much for me right now so I *really* need to fix Air Link. Thanks in advance!


Accepted Solutions

Hey there, @Rextherunt! We see your Air Link cannot connect to your PC. We know how exciting PCVR can be when working, and we wouldn't want your VR experience to be anything less than stellar! It seems like you've discovered a solution to fix your issue. However, if you encounter any further issues, please don't hesitate to contact us. We're always here to assist you!

For anyone else still experiencing issues with the headset not finding your pc, please feel free to reach out to us in a private message! Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

View solution in original post


Expert Trustee

Opposite problem as me then. I can always detect the PC, and pair with it. But so far... Air Link has only actually launched twice, out of over 30 attempts. The two times it did work, I had to start with Air Link disabled both on the Quest and my PC. I then had to turn it on in the PC first, using either Oculus Link (which also isn't working often right now) or Virtual Desktop. Then I'd turned it on in the Quest, and it decided to work. Strangely, that "turn on via PC then Quest 2" tactic so far has only worked if streaming my PC to the Quest already. If I try doing so by lifting the headset (so I can see what I'm doing) and using the PC directly, it hasn't actually worked.

Lo, a quest! I seek the threads of my future in the seeds of the past.


I have the same problem, really hoping that someone can provide a fix because this is super infuriating .... 

Expert Trustee

One thing I had to do was to have my desktop plugged into the router and have it connected to the 5g wifi network my quest is on, at the same time. Also, don't forget to open up the Oculus app on your computer and turn on Air Link. While that stays enabled in the quest once set to on, the desktop app will turn it off after 24 hours. And defaults to it being off when the app is first started up too.

Lo, a quest! I seek the threads of my future in the seeds of the past.

I got mine working, try enabling dev mode in the app on your phone.

Settings / devices / development mode ~ There's a toggle there

Hope that helps you too 🙂


MY DUDE! Dev mode, the answer to all life's problems XD

Turn dev mode on using your app on your phone. 

Open the Oculus app on your phone and go to

settings /  device / development mode ~ There's a toggle there. I had to turn it on and off again and then reset the headset a couple of times to get it to work but as soon as I saw it registered in the headset (there's a new settings menu towards the bottom for dev mode) it worked fine 🙂 

Good luck dude.


Having the same exact problem.

Quest 2 is already set for developer mode.

I have a Ubiquiti UniFi WiFi6 AP wired into a Ubiquiti US-8 network switch, and my PC is wired directly into the same network switch.  The only SSID broadcast by that WiFi6 AP is a unique name I set up exclusively for Quest 2 to connect to, and there is no 2.4GHz network broadcasting on that same SSID.  Virtual Desktop VR game streaming works absolutely fine, and all other network connectivity between the PC and headset works fine, but not Air Link.  My Oculus client software shows the Quest 2 as a known device because I've previously connected it to the PC using the wired Oculus Link cable.  I've checked my Windows firewall settings and verified that the Oculus client software has a correctly-configured-and-enabled set of inbound rules applicable to all network profiles (Private, Public, Domain, etc).  I have the Air Link "experimental" setting enabled in the Oculus software.  My router (a Ubiquiti ER-12) shows that both the Quest 2 and the PC are assigned IPs on the same subnet, with no firewalling of any kind between them.  As far as I can tell, EVERYTHING is configured correctly EVERYWHERE, yet the Quest 2 still refuses to find my PC.  It just searches forever and never finds anything.

You seemed to have gone through the same steps as I have. Were you able to find a solution in the end? I tried with ALVR and it works once I set the IP static in the software, but Virtual Desktop Streamer nor Airlink works. I also tried Virtual Desktop Streamer with my laptop and it works, so I suppose it's the LAN connection that's bothersome

Honored Guest

i had this problem before, i restarted my router and my pc popped up on airlink

Restarting my router accomplished nothing.  This is clearly a defect in the Air Link implementation.


Why don't they just provide a way for me to TELL it the hostname and/or IP address I want to connect to?  I don't need it to "find" it for me when I already know it.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?