cancel
Showing results for 
Search instead for 
Did you mean: 

Air Link has stopped working but Link Cable still works

vacationlover
Level 4

I have been using Air Link ever since it became available in Beta, and I was using the Link Cable before that.  I last used Air Link perhaps a week ago, but today it doesn't work.  There have not been any changes to my PC that I'm aware of.

When I open Quick Settings, and select Air Link, it lists my PC, but says Not Connected.  If I select the PC, it displays the Pair button (even though it was previously paired).  When I click on Pair, the button is greyed out, but nothing happens.  No code appears on my PC.

I have tried the following:

1) Tried using the Link cable, and it works.

2) Rebooted both the PC & Quest 2 headset.

3) Updated the software on the Quest 2 headset.

4) Re-installed the Oculus app on my PC.

5) Verified that the Quest 2 headset is connected to my 5 GHz private network.

Does anyone have any other suggestions?

Thanks in advance!

 

1 ACCEPTED SOLUTION

Accepted Solutions

Finally found the solution.  After many messages back & forth with Meta Quest Support, one of the reps suggested that the problem might be with my internet provider.  That got me thinking that perhaps the headset wasn't getting connected to the internet (although I don't understand why it needs to, since I'm merely trying to Link it with the PC in order to play a game on the PC hard drive).

So I looked at the "Notifications" section in my BitWarden Firewall, and saw that OVRServer_x64.exe had been blocked "due to customer requests".  I don't know who had requested it, nor why, but I manually added an Exception to the Rules, and that solved the problem!  When I went to the Air Link settings, and clicked on Pair, the Link Code appeared in my headset and in the Oculus app on my PC, and Air Link works again!

View solution in original post

11 REPLIES 11

vacationlover
Level 4

One more thing...

I just used a CMD window to Ping my headset's IP Address, and it showed zero lost, and an average roundtrip time of 54ms.

Larry_O
Level 4

I constantly have the same issue. What I need to do to get an over 50 % hitrate is to reboot both my laptop and headset. Then it has a chance to connect. I heard VD has similar issues so this is the cheapest fix for now.

Hi Larry.  Thanks for your thoughts, but as I mentioned, I already tried rebooting both the PC & Quest 2 headset.  Also, I guess my issue is different than yours, because I've been using Air Link constantly for a long time without any problems.  This is the first time the issue has occurred.

Well, constantly in my case means during the last few days. I play several times a day and need to reboot everything every time i want to play again. I had no issues in summer time, last time I played prior these few weeks. 

 

Unfortunate if it doesn't work for you rebooting everything but must say it's no solution but rather a pain in the butt. 

as my laptop is in a separate room and to go an reboot it like five times in a row at worst to get a game running is **bleep**. I have had issues lately with desktop launched steam games as they stay 2D or freeze so needed to reboot on occasions even when i have a connection. None of these issues existed to this extend half-a-year ago. Now I have to launch steamVR from Oculus home to get games running. Thus there must be something bigger at wrong( i also have issues with the new pro-controllers requiring constant reboot of the headset and it begins to be annoying).

Hope you find a working solution.

Hey there, @vacationlover! We understand that you are having issues with your Air Link not working, and we know how that can spoil your VR time. Please don't stress over this; we will help you get this worked out. To be able to understand your issue a bit better, can you tell us the following information:

 

  • Are you using a PC or a laptop?
  • What operating system are you using?
  • Have you updated your headset or anything on your computer recently?
  • What kind of Wi-Fi network do you have set up?

Once we have the answers to these questions, we will be able to assess the best course of action from here.

Hi there.  Thank you for your quick reply.  Here is the info you requested:

  • Are you using a PC or a laptop?  Desktop PC
  • What operating system are you using?  Windows 10 Home
  • Have you updated your headset or anything on your computer recently?  Not before the problem started.  Afterwards, I checked my headset and found that there was an update available, which I installed.  I couldn't tell if there was an update available for the Oculus app (how do I do that?) so I  downloaded & installed it to make sure I had the latest version.  Neither of those changes solved the problem.  The most recent Windows Update was KB4023057 on Nov 17th, and Air Link was working fine after that.
  • What kind of Wi-Fi network do you have set up?  5 GHz, 802.11 a+n+ac, WPA2 Personal

Thanks for your help, and have a great weekend!

Thanks so much for that information! We know how important it is to get Air Link working again, and we want you to enjoy all your games to the fullest. If you have not done this yet, we suggest repairing the Meta Quest PC app to solve this issue.  

Please follow these steps to repair the Oculus PC app:

  1. Go to www.oculus.com/setup scroll down to "Oculus Rift S" and click Download software.
  2. Select "Repair".
  3. Allow the repair process to run, download and install.
  4. Launch the Meta Quest PC app.
    • If Windows asks you if you’re sure you want to open this file, click "Yes".
    • If Windows Defender prompts Windows protected your PC, click "More info" and then click "Run anyway".
    • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
    • Please remember to re-enable your antivirus software once you've completed the repair.

Please give it a shot and let us know how it goes!

Hi.  Thanks for another quick reply.

I followed your instructions and repaired the PC app.  Unfortunately, that did not change anything.

When I open Quick Settings, and enable "Use Air Link", it lists my PC under "Available PCs", and underneath says "Not Connected".  When I click on my PC, and then click on "Pair", the button changes to a greyed out "Launch", but nothing happens. No code appears on my PC.

By the way, as I mentioned in my original post, after this problem started I went to the Quest Setup webpage, scrolled down to "Quest" and "Link Cable" (instead of "Oculus Rift S"), clicked "Download software", and selected "Repair".  How is that app different from the one you just had me do?  Is my PC now confused? 

I just now ran the OculusLogGatherer (after reading about it in another forum post), and my log file is absolutely full of error messages, so hopefully that will show you what's going on.  How do I attach the Log zip file?

When selecting the repair option for "Link Cable," that is primarily used for the headset itself, not so much the PC. So your PC will be just fine. It seems that issue needs an expert to look into it. In order for the logs to be checked, you can create a support ticket here. They have more tools at their disposal to assist with this issue. If you need some help creating one, please let us know. We'll be more than happy to help.