cancel
Showing results for 
Search instead for 
Did you mean: 

Air Link, steam link, vr desktop all not working

Zedorous
Honored Guest

Hi,

Recently got a quest 3 and want to use it to play games off my computer to utilize its power. Playing over a cable works fine, however, I have been unable to use any wireless connection.

Any time I load into Airlink, steam vr, or virtual desktop, I can load my desktop just fine, I can even stream videos online no issue. However, upon launching a game (any game vr or other wise) things proceed fine for about ten seconds and then I lose connection.

The Quest 3 continues to upload inputs but all downloads of what the computer is telling the quest to display fail. In essence, the game crashes.   The only way to get back to the desktop from this point on my quest is to close out of steam vr manually on my pc.

Disclaimer: this issue is not a pc performance issue not is it wifi speed strength

I’ve tried the following:

changing the current OpenXR runtime to oculus in the oculus app( this fixed the issue the first time I tried it and never again)

reinstalling steam vr

uninstalling steam vr and running games without it

disabling my firewall and antivirus

altering openxr runtime in settings of the various streamers(oculus app, Virtual desktop, steam vr)

uninstalling the oculus app

uninstalling virtual desktop

Any thoughts cause I really want to play wirelessly.

@

8 REPLIES 8

MetaQuestSupport
Community Manager
Community Manager

Hi @Zedorous! Thank you for reaching out to us regarding your issue with Air Link. We'd love to assist you as best we can so that you may continue to enjoy your experiences in the wonderful world of VR! With that being said, we have a couple of questions for you, as well as a few tips:

  • Has Air Link worked for you in the past while trying to play games?
  • Can you provide us with a list of games that you are experiencing this issue with?
  • Is the router in the same room as the PC?

Best practices:

  • Have the PC connected to Router/Access Point via Ethernet cable and not Wi-Fi
  • Headset should be connected to Wi-Fi via 5GHz band (AC or AX)
  • Router in the same room as the headset or in line-of-sight, and at least 1m (3.3ft) off the ground
  • Non-mesh network configuration

Once we have this information, we can look deeper into this issue. Let us know if the provided information is helpful!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi, 

The only game I have successfully used air link on was beat saver for all of ten minutes.

 

I have tried using it on beat-saber, half life Alex, portal vr experience, phasaphobio, and Skyrim VR. This issue also happens when I play any non-vr game as well of which I’ve tried many.

I am using a dedicated Prisim XR vr purposed router, the router is designed for vr with a direct connection to by computer using 2 HDMI 3.1 ports so I doubt the connectivity is the issue. When doing my testing I’ve had the router on my desk like 4 feet away from me so I’m getting data transfer rates of like 2000 mbps.

Hey there, @Zedorous. You mentioned you tried non SteamVR games, but we did want to clarify, have you tried and Oculus specific programs, free or otherwise?

We know how important the wireless VR gaming experience can be, and we would love to assist you however we can. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi,

any programs that I run directly from the oculus itself work perfectly fine, currently I only have “The light brigade” on my oculus but I’ve tried several other game demos and they have all worked flawlessly. The issue only arises when playing games wireless from my PC’s steam library. 

Hey there @Zedorous! Thank you for going into to detail about the issue. This helps us get to a resolution quicker. Frequently, a weak PC specification might be the source of a problem with the air link and computer. Certain features won't function correctly in this situation. To examine the specifications for link, click here. We hope you now have greater understanding. Tell us if this isn't the case so we may determine whether more troubleshooting measures are required. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi, the issue for sure isn’t pc specs, got - etc 3038 for my graphics card that’s up to date, quad core i7 11th gen intel cpu, and 48 gigs of ram

MetaQuestSupport
Community Manager
Community Manager

Hey again, @Zedorous! The symptoms you're describing seem to indicate a "choking off" of visual data coming to the headset, the odd part is that it starts at all--usually when we see this sort of issue, there is no graphical data passed whatsoever, but your system beginning to send the information tells us it's not likely a port blocking issue, though there could theoretically be a throttling issue of some sort with the graphics chipset, or graphics processing being diverted to the an onboard lower-end graphics processor instead of your high-performance graphics card that might cause this behavior. We've also seen some environments where the visual throughput will suffer or drop due to Wi-Fi instability hiccups regardless of recordable throughput speeds, though these usually occur in mixed-network or mesh setups. Have you by chance tried isolating down to having the router broadcast only on the 5ghz network, eliminating the 2.4ghz broadcast altogether?

 

We would really like to look into this deeper with you, but we'll need to get a support ticket created for you to do so, as our support specialists will have some additional troubleshooting tools at their disposal and will be able to collect and view your logs. Send us a private message by clicking on our name or clicking here to get to our profile page. Then, click "Send a Message" and we'll be able to respond to your shortly! Keep in mind that you must be signed into the community to send private messages. Once we're in a less public space we'll be able to get the information we'll need to create that case for you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

We see your private message, @Zedorous, and will continue with you there!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?