Showing results for 
Search instead for 
Did you mean: 

Air Link

Level 4

Whenever I open the air link tab inside my headset it opens a window saying “Air link connection lost. Check the network connection on your PC and headset, then try again.” I don’t even connect to a device and it constantly shows up, this only started happening on August 1st but was fine before. I’ve already tried restarting devices, closing oculus app with task manager and even factory resetting the headset itself. Nothing I do works. For a couple days before this issue occurred I wasn’t able to launch games like Roblox in VR, it’d just put me in normally.


do you know when is v43 coming out?

ive found that once the issue begins happening, restart your pc and it should be fine, each time u power off ur headset I have found that you need to restart your pc again.

don't work ...

Level 2

don't work....

Hey @Leoric3! We see you're still having issues. We'd be very happy to guide you through this as we know your gametime is very important.


We're providing a link here on best practices for Airlink. Here is a link for connection troubleshooting.


Lastly, here is the link on how to repair the Oculus app. 


Let us know if you still need assistance!

still not work 

Thank you for your response. At this time, we'd like you to contact Meta Store Support here and open a support ticket for further assistance.


Looking forward to it!

None of the options available in support have any relevance to Air Link - what one should be used?


Air Link used to work but is completely hopeless now. The app on my PC says i's connected but the headset says it's not connected.

Still does it after I restart. Any better fix now?