Showing results for 
Search instead for 
Did you mean: 

Air link connection issue

Level 2

I am trying to connect oculus quest 2 with the PC. I am able to connect easily using the cable. However, when I try to connect it through Airlink, it does not show any devices in VR headset air link even though the app is running in PC.



Community Manager
Community Manager

Hello there! We see you're having issues with Cable link and Air link. That's not the kind of experiences we like to hear about. So let's take a look and try to get you into the game quickly!


First, we're going to include a link here containing specifications and troubleshooting for the Oculus Cable link and Air link for your review.


Once reviewed, please let us know if you still need assistance.

Level 2

hey I am trying to connect my computer to quest link/ air link, but it says not connected and even when I try it doesn't let me connect.

Hey BrodiePlayz! We see that you are having issues with Air link and link cable. We want to get you back to gaming so let us look at this together to make sure we get you pointed in the right direction. In order to move forward we will require some information to help us better understand what is going on. Could you please provide the following for us:


  • What error messages, if any, do you see?
  • Has air link/link cable every worked for you?
  • When did this start happening, and when it did start happening did you do anything different with your computer or your device?
  • Have you tried any troubleshooting steps yourself?
  • Send us a screenshot of the error you are getting.
  • To check to see if your device is compatible, go here

Once we have this information we can move on to the next steps.


Hey BrodiePlayz! We are just following up to see if you were still needing help with your link connection issues. If you still need our assistance just reply back at your earliest convenience with the requested information and we can move on to the next steps. 

Level 2

Whenever i do it, i am able to get my compute on oculus air link but I am not able to click the  blue button at the bottom. when unequip and reequip it changes the words but i can not click the button

Hey there @MonkeyMike628! Oh no, having issues with your airlink can definitely be troublesome! For clarification, could you provide us more information on the issue that you are having as well as picture/screenshot of the issue? Also have you attempted any troubleshooting steps? If so, can you let us know what you've attempted? Please make sure of the following: 


  • Try rebooting your device 
  • Make sure you meet PCVR requirements 
  • Make sure you are using the same network on your PC and headset

Let us know if you were able to fix the issue. We look forward to hearing back from you! 

Hey there! Just squeezing in and seeing if you still needed help with your PCVR issue. Please reach back out if you still need some assistance. We are always happy to help.