Showing results for 
Search instead for 
Did you mean: 

Air link not loading

Honored Guest

Yesterday I was using my airlink with my PC fine, but when I installed Phasmophobia on steam today to play it on VR I used airlink to connect to my PC and it's just stuck on the 3 dots loading endlessly. I can hear audio from my computer though. I've tried loads of stuff like uninstalling the app and restarting both devices. Nothing has worked so far. 


Community Manager
Community Manager

Hello @mrtoast173! We're sad to hear that your VR experience has been interrupted! We'd love to assist you in getting this issue resolved! We have a couple of troubleshooting steps we'd like you to try, 1 at a time, if you hadn't already:

  1. Are you able to un-pair and re-pair your Airlink?
  2. Reset the whole system. Start with restarting the router, then the PC and finally the Quest device, in this order
  3. Finally, factory reset the Quest device if all else fails. 

We hope we were able to provide a resolution. If you find that you need further assistance, please don't hesitate to @ us! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?