cancel
Showing results for 
Search instead for 
Did you mean: 

All apps crash (Win7, GTX970, SDK 0.8.0.0)

stenyak
Protege
(moved from general forum)
I'm running Nvidia drivers v358.78, oculus sdk 0.8.0.0, windows 7 64bit.
DK2 is connected directly to the HDMI port, while the main screen (1080p@60Hz) is connected to one of the two DVI ports.

I've downloaded several games that are all marked in share.oculus.com as either "0.6.0+", or greater version number.

- 1 of them is Unreal based, and it launches, but the DK2 does not work (I'm left with a regular non-vr experience).
- 6 of them are Unity based, and they all crash seconds after launching.

All the logs and crash files from unity games look very similar. Here's a recollection of the relevant log lines I have found, and attached are 3 files found in one of the crash directories.

(0x64533893) (OVRPlugin): (filename not available): ovrp_Update + 0x13a3
(0x64533D90) (OVRPlugin): (filename not available): ovrp_Update + 0x18a0
(0x64532269) (OVRPlugin): (filename not available): ovrp_SetEyeTexture + 0x19
(0x64951924) (OculusPlugin): (filename not available): (function-name not available) + 0x0


000007FEF79F3A3C (OVRPlugin) ovrp_Update
000007FEF79F3EC5 (OVRPlugin) ovrp_Update
000007FEF79F246D (OVRPlugin) ovrp_SetEyeTexture



OVR Error:
OVRTime: 980.154380
Time: 2015-10-28 22:02:21 [799:884:200]
Code: -3000 -- ovrError_Initialize
System error: 5 (5) -- Access is denied.
Description: OpenProcess


Unity Player [version: Unity 5.1.3p2_bebcb01d8ab6]
OVRPlugin.dll caused an Access Violation (0xc0000005)
in module OVRPlugin.dll at 0033:f5153cfa.


As you can see, "OpenProcess" is mentioned as a possible cause for the problem. I have rebooted the computer (to make sure there are no running left-overs from any game) and it still shows the same message.

I have also tried closing the Oculus Config Utility (right click on tray icon, "Exit"), but the same log lines (with "OpenProcess") are generated.

In all the cases, the DK2 light stays yellow, while the tracker camera light stays off all the time.

appdata\local\oculus\ovrserver minidump link: https://mega.nz/#!1ptQHKbT!PLeY-lROXfxv ... V0zzsny-Lc

If you need any more information, please let me know.

Thanks for any advice!
9 REPLIES 9

cybereality
Grand Champion
Can you make sure you have Windows 7 SP1 and this update?

http://www.microsoft.com/en-us/download ... x?id=36805

For Unreal games, you usually have to press ALT+Enter for it to go into VR mode.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

stenyak
Protege
Thanks for the reply.

It says the update is already installed: http://www.stenyak.com/sharex/2015-10-28_23-46-26.png
My Windows 7 install is: Windows 7 Ultimate Service Pack 1

In the unreal game (Mythos of the World Axis), downloaded from share.oculus.com, when pressing alt+enter, the window size gets bigger and the task bar is hidden, but it's still not fullscreen, and the DK2 still does nothing (no image in there).
I noticed that the blue camera tracker light turns on for a second or two before it turns off again, during startup of this Unreal game.

The rest of games (Unity-based) are still crashing as usual.

stenyak
Protege
Do you need any more information to proceed? I can do any test you think can help.

cybereality
Grand Champion
I see this error, which seems to be the problem.

OVR Error:
OVRTime: 2098.823586
Time: 2015-10-28 22:21:00 [491:652:300]
Code: -3000 -- ovrError_Initialize
System error: 5 (5) -- Access is denied.


My guess is that your Windows account is limited or some other security settings. Please make sure you're on an admin account, and uninstall + reinstall the Oculus Runtime with right-click "run as admin". I would also disable or uninstall any anti-virus software, as there are known issues with ZoneAlarm, Comodo and Norton.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

stenyak
Protege
"cybereality" wrote:
My guess is that your Windows account is limited or some other security settings. Please make sure you're on an admin account, and uninstall + reinstall the Oculus Runtime with right-click "run as admin". I would also disable or uninstall any anti-virus software, as there are known issues with ZoneAlarm, Comodo and Norton.


Thanks for the advice. Unfortunately none has helped. Specifically:
- My user already is an administrator account. But just in case, I created a new admin account exclusively for testing again.
- I uninstalled all software made by Oculus.
- Then I installed using "run as admin".
- I run the unity games as admin too.
- Even bypassed the games launcher (if it existed) and went directly to "run as admin" the game exe.

In all cases I'm still getting the same errors.
I have no antivirus enabled in my computer, and I'm using the default windows firewall (which has not complained about anything yet).
After disabling Windows Firewall, the same errors appear.

Let me know if I can do anything else to help you find the issue. Thanks!

cybereality
Grand Champion
So I was mistaken. It looks like your game is being run as admin, which is not supported. The service runs at normal user level (assuming you haven't messed with it in any way), and the games must also be run at normal user level. If either is elevated, you will get an error similar to this.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

stenyak
Protege
"cybereality" wrote:
It looks like your game is being run as admin, which is not supported.

That was exactly right. After creating a NON-admin account, I am now able to run all dk2 games. It's a pity I have to switch user in order for it to work ("right click" -> "run as another user" -> unprivileged user, does NOT work correctly, I have to really log into the unprivileged user account).

Thanks a lot for your help. I hope this thread helps other users experiencing the same crashes that I had 🙂

SirJungle
Explorer
I'm on Win 10 with 0.8. GTX 980 Ti. I'm able to get all unreal apps to work, all Unity apps crash.

cybereality
Grand Champion
Can you provide these log files? viewtopic.php?f=34&t=23521

Please upload as attachments or use the code tag. Thanks.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?