cancel
Showing results for 
Search instead for 
Did you mean: 

Any fixes yet for the black desktop

MaxAMillion1
Honored Guest
 I use the Meta Quest 3 and a link cable to connect with my Asus ROG Zephyrus G14 laptop via USB-C. When opening the Oculus universal menu in the headset and pressing the desktop button, it presents me with a black screen rather than my desktop. Throughout my research and testing, I have concluded that this is a common problem among laptops that use integrated and dedicated graphic processing. To that end, it is possible to set the Oculus app to use integrated graphics, which causes the desktop function to work as intended, but performance is significantly decreased and not viable for gaming. This is a KNOWN issue, and I want this to gain some attention and see if there have been any possible solutions. If not, how can we make one? 
 
Here is a video of the problem: https://www.youtube.com/shorts/-uirBzZ2Fz0
 
Here is a list of things I have tried: 
-Drivers
-Windows versions
-ports on my laptop
-disable HDR
-MUX switch 
-Setting application to high performance
-Disabling the iGPU
 
PC Specs and other info:
 Model: Asus ROG Zephyrus G14 laptop
 GPU: 3060 Mobile, 6 GB VRAM
 CPU: AMD Ryzen 9 5900HS with Radeon Graphics 3.30 GHz
 RAM: 16.0 GB
 Headset: Meta Quest 3, using PC via link cable.
5 REPLIES 5

bleburys
Honored Guest

Hey your description inspired me!
I also encountered this problem. I thought that all notebooks with new graphics cards had this problem. However, after reading your description, I found out that this problem only occurs in notebooks with both discrete and integrated graphics. So I took the following measure and successfully solved the problem:

Enter bios and set the graphics card to Discrete

Good Luck!

Hey, thanks for the reply, unfortunately setting the Graphics setting to discrete is not a good solution as it will then render all VR processes on the weaker integrated GPU, therefore it's not a viable solution. What we really need is for META to recognize this bug and fix it to allow for the dedicated GPU to show the desktop!

Setting the Graphics setting to discrete in the BIOS means letting the laptop to only use the stronger discrete graphics card and ignore the weaker integrated GPU. So all your VR rendering, including other computer processes, are rendered using 3060.

Meta Recognizes this problem, and what i've gotten as a response is: 

"I understand that your Quest Link does not work unless your Radeon Onboard Graphics are disabled. Rest assured I will try my best to assist you.
Upon looking into this, it seems that your laptop graphic model is not compatible with the Oculus Pc Software."


So I hope there is a clever programmer who can make a patch for the community. 

 

As a temporary solution i've got two .bat BATCH files on my desktop. which I run before and after the oculus software that disables/enables the onboard gpu. in the files are the strings: 

pnputil /disable-device "PCI\VEN_1002&DEV_1636&SUBSYS_8787103C&REV_C6\4&12C9051D&0&0041"

The string should be replaced by your own hardware-id onboard gpu string.

Hey @MaxAMillion1! We know how important it is for our customers to be able to use their devices in PCVR and how not being able to do so can take away from your overall VR experience. We would like to look into this deeper for you and ask that you send us a private message to get this started. To do so, please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. We hope to hear back from you as soon as possible.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!