Showing results for 
Search instead for 
Did you mean: 

Assassins Creed Nexus Crashes on Launch


What's the Problem?

I was able to play 1.5 hours of AC Nexus, after which my game kept crashing. The game crashes on launch, about 5-10 seconds after pressing play on the app.

What Have I tried ? 

Unfortunately uninstalling, and reinstalling did not yield any results. I even factory reset my headset, and reinstalled AC Nexus but still no luck. 


Has anyone managed to find a fix, or is this a patch the Dev team will hopefully release? 

I noticed the current version on the Meta store is from 2/11/23 , a couple of weeks earlier than the release date, so there was no 'day one' patch. 


Accepted Solutions

Meta Quest Support
Meta Quest Support

Hey everyone. I'm sorry to hear that this issue has still been ongoing for you, so I'd be happy to hopefully point you in the right direction. 

Seeing as the issue is only with Assassins Creed Nexus VR, I would highly suggest reaching out to Ubisoft for them to get a more in-depth look as there could be something going on through their end. Along with that, I would also recommend submit bug reports for our engineers to catch wind of this. I wish there were more I could provide, but this is the best option I was able to find at the moment.

Sometimes it's okay to be a little Bing Chilling

View solution in original post


Honored Guest

I'm having the same issue, No fix so far, If you have found a fix please let me know

Tried using the Quest games optimizer, yet still nothing. Even checking the performance monitor doesn't yield obvious results.  Such a shame for the game, a I'm itching to play !

Honored Guest

I have the same problem, I get the ubi splash but then I just get floating triangles and nothing happens. I'm on quest 2


 Did you see this error aswell ? ^

I got the exact same problem on Q2, it works well on my Q3.

Did you find a solution ?

Update, The issue has not been resolved but I have found an alternative fix. After contacting Meta support, they refunded me as they could not help me further. I created a new Meta Account, repurchased the app and it works. Not ideal but it works

Hi there @sebastien.genou, we noticed that you are needing assistance with your Assassin's Creed: Nexus game. We understand how inconvenient a game crashing is, and we want to do all that we can to look into this for you. Being able to play a game that just came out can be very fun and it's important we help you out on this matter!


So that we can narrow down the issue, can you please let us know of the following:

  • Does this happen with any other game?
  • Are you using the same account both as admin for the Quest 2 and Quest 3?
  • What troubleshooting have you done yourself?

We also noticed that @ahward21 has found something that works for them, if you want to look into it.


We hope to hear from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for your help !

  • Does this happen with any other game? : No, i can play all my other games on my two Quests.
  • Are you using the same account both as admin for the Quest 2 and Quest 3? Yes i am the admin on both Quests. The problem occurs with a secondary account (that of my son) on my Quest 2 where it has not been installed on the primary account (it is installed with my account on my Q3).
  • What troubleshooting have you done yourself? I've tried freeing space, rebooting, launching it a couple of times. Don't know what to do more.

We also noticed that @ahward21 has found something that works for them, if you want to look into it : " I created a new Meta Account, repurchased the app " it is not a solution, i have an account with more than 300 apps, i don't wan't to create an account just for that game...

Thank you again !



Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?