cancel
Showing results for 
Search instead for 
Did you mean: 

Beat Saber - Won't update and now won't reinstall

JJMacCrimmon
Level 2

Right after Meta changed out the logos on my Oculus 2, Beat Saber refused to update (1.24.1).  Updated the Oculus system version but that didn't help.  Recently I saw that another new version was out (1.25.1).  Again, Beat Saber would not update (from any command source - quick link, store, detailed summary - nada).  Following another game forum, it said, uninstall and re-install the game.  Now Beat Saber won't re-install.  WTF?  

Why is this so messed up?

10 REPLIES 10

MetaQuestSupport
Community Manager
Community Manager

Hey there! That's quite the issue there with Beat Saber, so we'd be glad to lend a hand.

 

In order to gain a bit more insight, could you please answer the following:

 

  1. When was this first noticed?
  2. How much storage space is there currently in your headset? 
    • Keep in mind the storage should be at least 2x that of the recommended for the app.
  3. Does this only happen with Beat Saber, or other apps as well?

 

We look forward to your update! 

MetaQuestSupport
Community Manager
Community Manager

Hey, we just wanted to check back in with you. We're you still needing help installing Beat Saber? 

I am also facing this issue.i think i started seing it for the first time 9 weeks ago when the device updated itself

oculus quest 2

system version 47421700667400000

version 46.0.0.226.406523063

runtime version  46.0.0.226.0.406523266

 

i have 193 gb of space,app requires 220 mb

 only app that i had that requires update was Echo Vr and that one could be updated

reinstalling beat saber fixed the issue,but it was annoying

Introv3rse
Level 2

I had the same issue and tried everything you did. I even deleted all data pertaining to Beat Saber from the cloud storage. I disconnected/shut off the internet and tried different networks. I un-installed and re-installed the Meta/Occulus app from my phone and even attempted to install Beat Saber from the app. No luck.

 

After confirming that all of my purchases related to Beat Saber appeared in my Meta account, I did a factory reset on the Occulus. After it went through it's updates, I was able to install Beat Saber without any issues. 

AnxiousRaccoon
Level 2

I am having the same issue, and I found a fix. I just bought the Meta Quest 2 and first started playing it on Monday November 28th 2022. The only thing that I have put on it is beat saber. It worked Monday, Tuesday and Wednesday. I didn’t play Thursday and I am now trying to play on Friday. I click on the game and it says that it needs to reinstall. When I try to reinstall nothing happens. I then tried to uninstall and again nothing happened. So I came here searching for answers and have done everything mentioned above and it still will not work. I have checked internet connection, power, space, files, updates, etc.

I ended up having to go to my notifications and hit cancel then delete on the queue of reinstalls and uninstalls from me attempting to get it to work. After hitting cancel and delete on every individual request, one at a time, I restarted the headset and I was able to reinstall and play fine right away.

Hey there, @AnxiousRaccoon! Thanks for sharing this information; we sure do appreciate your expert problem-solving skills! We hope that this works for others facing this issue as well. Props to you!

Hello, I am having the same issue. I am not having this issue with any other apps. Just beat saber. I have deleted all other apps and that seems to do nothing. 

Hello ThisGirl123. We are sadden to learn that you are experiencing problems with Beat Saber not updating and reinstalling, and we are even more disappointed that this is the sole game that is having technical difficulties. Please allow us to investigate this matter further for you.

 

  1. Do you have enough room to install the game again after the update?
  2. How long has the problem existed?

Good day, ThisGirl123. We are getting in touch with you again to check if you still need assistance with Beat Saber not reinstalling. If so, please don't hesitate to get in touch with us.