Showing results for 
Search instead for 
Did you mean: 

Black Screen when using Virtual Desktop in Oculus PC App

Level 4

UPDATE: Solution found by Hansaplastique! THANK YOU!


It seems this method forces Intel(R) UHD Graphics to render for OVRServer_x64.exe. At least, that's what's selected under "Power Saving" for my PC. My games still run fine using this method, since they still use the GPU. The dashboard/OVRServer doesn't utilize the GPU while in use. Changing the preferred processor in Nvidia Control panel for OVRServer_x64.exe does NOT solve the issue, although I thought it would effectively accomplish the same thing. 


Many thanks to Hansaplastique. You're a real gamer. I made a video tutorial for the solution for anyone confused.


Original Post Below



Oculus app isn't showing desktop, just black screen. Though, I can still control the cursor with my controller. I have a Rift S and a Quest 2 and both have the issue. So far, I've restarted, repaired install, and installed latest graphics card drivers but have had no success. I also completely uninstalled and re-installed and am still having the issue. Currently blaming the recent update. My Quest 2 is running on v. 27, because v. 28 is not yet available to me. But I doubt that's issue because my Rift S also has the problem. 


OLD 4/25/21: I've been working with Oculus Support, but so far no amount of troubleshooting has solved the issue. My working theories are:


1. Nvidia Optimus laptops

2. The new update just glitched out the integrated Virtual Desktop in the Oculus PC application.


This issue is not present on my Desktop computer. I run VR on a MSI GL75 Leopard 10SFK-029. I'm still able to play games, and the black screen is my only symptom. 


CPU: i7-10750H

GPU: 2070 (mobile)

RAM: 32gb at 2933 MHz


Accepted Solutions

Not applicable

Go it to work properly now without the need for an external monitor:


Go to Windows Settings -> System -> Display -> Graphics Settings (way at the bottom).

Under "Graphics performance preference" -> "Choose an app to set preference" -> "Desktop app".


Click "Browse" and select: C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe

Click "Add".

Select "Options" and set it to "Power saving", and click "Save".

Restart the Oculus software and Virtual Desktop now works properly.


This worked for me on an 2020 AsusROG with an nVidia 2070.

View solution in original post


Level 3

Having the same exact problem

Level 2

Having the same exact problem😭

Level 3

Yup, exact same problem here and I also suspect the recent Oculus update as the culprit. Happening on both my Rift CV1 and Quest 2 (also v27). On my CV1, the windowed black screen (instead of my desktop) is accompanied by stutter. I thought it might be some kind of conflict with the paid version of Virtual Desktop that I installed about the same time as the latest Oculus software update, but uninstalling Virtual Desktop made no difference. Are other people experiencing this issue also using two headsets connecting to the same machine I wonder?

Level 4

I’ve been working with Oculus support to troubleshoot it but no amount of uninstalling and reinstalling of the program, drivers, etc. has resolved the issue. An interesting development, my Desktop computer doesn’t have this issue, only my laptop. I wonder if Nvidia Optimus could be a part of the problem. I think the integrated graphics automatically kick in when rendering the desktop. I’m not super familiar with Optimus. Are any of you experiencing this on a Desktop?

I also believe it is a gaming laptop issue with the dedicated graphics card and Nvidia card. I had the same exact problem on my index and fixed it by creating permissions which forced steamvr to launch with my Nvidia card but that solution did not work for my Q2.

I believe it has something to do with your desktop display running off your integrated graphics card, which is why you are still able to run apps in another window and see them since they are launched from your Nvidia graphics card instead. It would also explain why you can see the mouse and click things, but the display is black because it cannot communicate to your desktop display through the integrated graphics card. Steamvr and other Q2 users had very similar problems and all had very similar solutions with getting steamvr/oculus to run specifically through the nvidia graphics card

Level 4

Is there a way to force the gpu to render the desktop? Also, I wonder why did this only recently become an issue.

Not applicable

I had the same problem on my AsusROG laptop.

I managed to get the Virtual Desktop to work by attaching an external monitor.