Showing results for 
Search instead for 
Did you mean: 

Black screen from a "SHELLENV keeps stopping" error

Honored Guest

My Meta Quest 2 has been performing flawlessly since I bought it in February of this year, but yesterday I made the mistake of downloading and trying to install Meta's Paradiso environment as a home screen and began seeing only this error message upon starting the headset: "SHELLENV keeps stopping".  Now all I get is a message asking if I want to exit the app or cancel and I'm hoping someone has experienced the same crippling result and can offer a suggestion on how to repair the damage caused by one of Meta's own apps!


Community Manager
Community Manager

Hey hey, @R0nMoore! We see you are having issues with your headset being stuck on the following error message "SHELLENV keeps stopping". We know how much this can hinder your gaming experience. So that we can try to resolve this issue of yours, please try to reboot your headset with the steps linked for you here. If this is has no success please use this link to factory reset your headset. 


If this after trying these steps the issue still persists, follow this link here to our amazing support team. They will be glad to help you knock this issue out! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

BOO! We're just reappearing to check in to see if you were still in need assistance, and if you were able to get a support ticket created. If you are still having issues, feel free to reach back out! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


Exact same thing happened to me. Had to reset my headset. I hope this will get fixed if it hasn't already.. 


Everyone you can fix this error by using sidequest app on your phone (need to support otg usb) or apparently using a PC.

You load sidequest then plug in the headset and this allows you to search the files on the headset (like a file manager) 

Now dont ask me how but I searched through for a file named shellenv and there's one in there with a longer name but "shellenv" is there. 

I clicked on this file but it didn't execute or anything . I really seemed to do nothing at all, I'm not even sure this step is necessary , it's just what I did. 

Feeling like I'd failed to do anything I unplugged the headset.

Upon trying on the occulus it had weirdly , for some reason reset itself to the original home enviroment. I'm guessing sidequest somehow overwrites the shellenv file and this replaces the original home screen enviroment or perhaps it deletes the corrupted file that's causing the problem , I don't know. All I care about is it fixed it for me. Seems its worth a try even if it doesn't work as youre not messing about with anything. Just looking at the headset like you would a USB memory stick.

YOU DO NOT NEED TO FACTORY RESET. I don't know why the support team are recommending such a drastic move when sidequest appears to be a solution. You can find other people explaining how they used sidequest and swapped out the shell env file but i couldnt do this. Wasnt an option using the pho e (this is how I originally found out about sidequest and gave it a try)

So to recap. I didn't use a PC as suggested by other posts I found I had no access to one.

 I merely used the sidequest phone app, plugged in my occulus to the phone. Looked through the files seemingly doing nothing(?). Unplugged it. Tried it on and the shellenv repeat shutdown error was gone.

Surely this is worth a try before some factory reset.especially if like me you have loads of games amd saves you don't wish to lose.

Hope it helps

Thank you SO much for providing this workaround!!  I also downloaded the Paradiso virtual environment, and it crashed my headset with the ShellEnv error.  I didn't have to locate the file name in SideQuest, but I restarted my headset after connecting to SideQuest and then unplugging my device.  You helped prevent me from having to do a factory reset!!  ❤️

I'm so pleased it worked for you! I bet you was as suprised as I was lol. Now we know we need only plug in sidequest and it fixes it. I didn't know if what I did (searching for file with shellenv in it and clicking on it) helped but it seems it wasn't necessary. That's good to know. We should let as many people know how to solve it as possible. I've answered a few and I'll keep pointing them to this solution if I see anyone asking for help. 

Happy new year mate!!! 😁

No, thank YOU for continuing the share the fix with all of us!!  I think it might have worked by just downloading SideQuest because SideQuest performs a mandatory debugging when you install it.  Whatever specific debugging scenario it ran, it appears to remedy the issue we were experiencing.

Thank you, again, for sharing your workaround!!  You already helped start my new year off on a positive note since I didn't have to factory reset & redownload everything!  I wish you the very best in this new year!  🙂

You're welcome, have a great year!

I get where coming from but I can't connect my headset without allowing it from my headset itself, and the message to allow it isn't popping up, is there a way to turn this off on the oculus app or what because I really want to fix this?