Showing results for 
Search instead for 
Did you mean: 

Black screen from a "SHELLENV keeps stopping" error

Honored Guest

My Meta Quest 2 has been performing flawlessly since I bought it in February of this year, but yesterday I made the mistake of downloading and trying to install Meta's Paradiso environment as a home screen and began seeing only this error message upon starting the headset: "SHELLENV keeps stopping".  Now all I get is a message asking if I want to exit the app or cancel and I'm hoping someone has experienced the same crippling result and can offer a suggestion on how to repair the damage caused by one of Meta's own apps!


Honored Guest

my oculus quest two is also having the same problem but after a 1 min or 2 it just restarts by it self please help me fix it I dont like it i just want to play please respond TY if you do

Sonic_dash if you search for a thread called 'ShellEnv close down error.' You'll see there's a kind of strange solution for this. It involves downloading sidequest and a simple quick use of it. Either use a PC or like me just use a phone with the app. (As long as your phone supports using USB otg -[on the go USB] you can connect your phone to your oculus 2 using sidequest)

Basically it seems to overwrite the corrupt shellenv. File causing this problem without you doing anything more than plugging sidequest in. Worked for me and others . If not you will have to do a factory reset but this loses all your saved game files and progress in games. And you would have to re-download all the content you have put on your headset. The sidequest fix avoids this. Anyway search the database , there's a couple of threads where I explained all this, I don't want to keep retyping it but I understand how you feel when it goes wrong so I answered here to help

Hope it works for you

Honored Guest

If this started happening after you tried to use paradiso, and your quest headset is already connected to your phone through the meta app, you can use the meta app to launch any app or game and once it starts on your quest headset you can open the quest settings to change your virtual environment to something that is not paradiso.

Thanks I hadn't thought of that as I didn't know you could launch an app from the phone. Yes the original problem was caused by the paradiso virtual enviroment. After changing it you're faced with endlessly repeating black screen and the shellenv close down error.

From the headset you can't do anything and most people try everything and end up doing a hard reset. 

If your suggestion works it's way easier than bothering with installing sidequest app etc. 

Hopefully others will see it. 

I can't test it myself as I have fixed mine and tbh I won't ever touch paradiso or the enviroment launcher again lol

Thanks for the tip tho I'll keep it in mind if I get other similar headset errors.  Try the oculus/meta phone app first.

Community Manager
Community Manager

Hey there @R0nMoore! Thank you for reaching out to to us regarding your experience with installing Paradiso. We want our customers to be able to enjoy any app of their liking, so we will definitely be happy to assist you.


Have you attempted to uninstall the app and then reinstall? Also with issues like this Factory resetting the device can be an easy resolution. You can do so by:

  1. Charge your headset to at least 50%, then turn off your headset.
  2. Hold the power and volume (-) button on your headset down simultaneously until the boot screen loads on your headset.
  3. Use the volume buttons on your headset to highlight Factory reset, then press the power button.
  4. Use the volume buttons on your headset to highlight Yes, erase and factory reset, then press the power button.

If you have any further questions in regards to this, feel free to private message us and we will be happy to assist you. You can do so by selecting our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Wow, that was an easy fix, thanks a lot

This should eventually allow you to , keep your headset on and it will eventually pop up but you dont have much time to use the + volume button to select it.

Sidequest also has a advanced feature to enable this but i dont know how

Hope this helps! - Foxache 😄

Honored Guest

Im having the same issue with my oculus I added this Rick and Morty theme environment and it’s the same thing I can’t factory reset it because it says no commands I tried resetting it but the same thing happened please help.

You can bypas it by starting a game remotely through your metaquest app, and when the game/app starts you can go and turn off the problematic program

Hey there @xXJOYTORXx! We were simply curious to find out if the steps our friend @ChickenWing_32  shared were effective. If they didn't work, please inform us so that we can delve deeper into the matter. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!