Showing results for 
Search instead for 
Did you mean: 

Black screen in Quest Link remote desktop

Hi Guys,


When I connect my Oculus Quest 2 with my laptop and try to launch the remote desktop, a black screen appears.

I can control the mouse cursor with the controllers, but no image is showing.


I already tried some solutions I found on the internet like resize the screen from the headset and set the OVRServer_x64 to launch in the integrated GPU but anything worked. I'm already assigned to the public test channel.


However, this problem is happening only in one laptop I acquired recently. I've tested in other two computers (other laptop and one desktop) and everything works fine. So, I think that maybe it can be related with the machine specs that I described below.


First laptop (not working)

- AMD Ryzen 7 5800H with an integrated Radeon Graphics

- Nvidia Geforce RTX 3060


Second laptop (working)

- Intel i7 10a gen with an integrated UHD graphics

- Nvidia Geforce GTX 1660 Ti


Desktop (working)

- AMD Ryzen 7 3700X (no integrated GPU)

- Nvidia Geforce GTX 1660 SUPER


All of them have Windows 10 Pro.