cancel
Showing results for 
Search instead for 
Did you mean: 

Black screen with Oculus Link virtual desktop (not Virtual Desktop app)

Thoort
Honored Guest

Hello guys!

Problem: when i activate Oculus Link and i click on the virtual desktop (not the Virtual Desktop app), i get a black screen on the window but i can see my mouse and move it. I really would like to be able to use properly this virtual desktop from Oculus Link.

Labtop: Asus Tuf Gaming x550, with Windows 10, NVIDIA Optimus (AMD Radeon RX Vega 10 Graphics + NVIDIA GeForce RTX 2060), a AMD Ryzen 3750H processor, 16GB RAM.

Device: Quest 2

Already tried: to upload all the graphic and usb drivers, the Oculus software, to restart them, to restart my computer, to turn off the AMD Radeon RX Vega 10 Graphics, to force the high Nvidia graphic performances on all the Oculus related applications i found (see attached)...

Do you have any idea to fix it?

Regards, Thoort

s44lmq7dv6kw.png8m2g6x94e0ko.pngin0q5h3l3v3l.pnggx2d8a3bu4uy.jpeg6h9ffrouvjgu.png

30 REPLIES 30

Crazy_Sane
Superstar

Hang on... do you have an AMD card, or an Nvidia card?

So the window that shows the desktop is black, but you can still see the home environment? What's on your monitor while this is happening?

Gagahenri
Explorer


Gagahenri
Explorer



Hang on... do you have an AMD card, or an Nvidia card?

So the window that shows the desktop is black, but you can still see the home environment? What's on your monitor while this is happening?



Hey ! I got the exact same pc and have a lots of issues, this one included, i'm actually trying to solve it so i'm here to get pingged when someone will find something

He only can the the mouse-over / And it moves on desktop too, but can't see what's on the desktop in VR
Yes he can see the Home environment

It's been 2 weeks, since i managed how to play in link with this laptop and Oculus support could find the issues and where just asking for logs when the issues comes from windows default settings and Nvidia control Panel... 
I had to configure everything by myself on this labyrinth of parameters...

And still, the quality aisn't perfect and lags here (vrchat) even with à RTX

He got and AMD Apu : which means, AMD processor + Radeon RX Vega 10 Graphics included AND an RTX2060

Thoort could you add me on Discord pls ? (Astalyos#5063)

Burgamus
Honored Guest
Following. I have an Asus ROG Zephyrus with the same issue. At first i couldnt get Oculus Link to work at all. The above method fixed it. Now it works but the Virtual Desktop is black like OP mentioned.  Oculus Support was no help. Had to solve through internet searches and trial and error. I'm really close to returning the Quest 2 completely if i cant get this fixed.

Tseu
Protege
Same problem here, zephyrus g14 rtx 2060, official cable, quest 2, no solution...

artem.yusipov
Honored Guest

exactly same problem here. asus strix, rtx 2060. was working well few days ago.

if you grab the black screen and move it you can then view the browser if its open on the PC, fixes my kids roblox issues anyway.  Hope it helps?

OgeyRrats
Honored Guest

Same issue here. Only happened after latest update on Quest 2. 

dickchappy202
Honored Guest

Has anyone found a Fix for this yet? I would love to get some help on it.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?