cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth mouse back button causes universal menu infinite loop when using Virtual Desktop

I just got a Logitech Bluetooth mouse to use with Virtual Desktop. It has the standard right-click, left-click, scroll-wheel and the two buttons on the side used to navigate forward and backwards in a browser (at least that's what I know them as). It is these buttons that create the issue.

When I am at the home screen with nothing else running, I can press the forward most button (I think this is usually the "GO BACK" function) and the Universal Menu appears, pressing it again dismisses it - fine, neat feature.

However, when I am using Virtual Desktop and I press that button, instead of forwarding the button to the remote PC or behaving as it does in the home screen, it causes the Universal Menu to appear and disappear about once every seconds forever. I have to press it again while the Universal Menu is being displayed (less than a second at a time) to get it to stop. But once this has happened, any method I use to invoke the Universal Menu just resumes the infinite loop - so meta button in hand tracking or touch controllers, etc. I have to fully exit out of Virtual Desktop and restart it to return to normal functionality. 

3 REPLIES 3

MetaQuestSupport
Community Manager
Community Manager

Hello there, @404.invalid.syntax! Having the menu continually open and close can be distracting and certainly not ideal when using the headset. To help narrow down the possible cause, we would want to remove the batteries on the controllers to ensure that it is not a button getting stuck or being repeatedly pressed. Next, we would want to open the menu outside the virtual desktop to check if the same issues occur. Third, we would want to try with another mouse, if available, to help isolate any issues with the mouse. 

 

We hope this helps, and please let us know the results of this to help us investigate further. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi, thanks for the reply!

  • I tried removing the batteries in the right controller to confirm it's not a stuck button (but this gave me an idea...)
  • It does not reproduce outside of Virtual Desktop, so it seems to be a conflict with that application
  • I do not have another bluetooth mouse to check, I bought this one for this purpose. I will try to find an adapter to connect a wired mouse when I get home.

I think you might be on to something in regards to the stuck button, except that it's a stuck virtual button. I know from fighting Arduino HID code that keys and mouse button presses are not registered as a ON/OFF they are two separate signals KEYPRESS and KEYUNPRESS (or something like that). I'm betting that Virtual Desktop hears the KEPRESS, but because the Meta Quest OS also captures this signal, it's already put the Virtual Desktop app in the background, so it's not able to register the KEYUNPRESS signal. And since it's forwarding input signals and it's tasked with interpreting them, it thinks the button is being held down, so it keeps spamming it. I tried to test this theory by timing the button presses perfectly, but it was too finicky to get an obvious confirmation. 

If that's the problem, the solution will probably involve handling that case either by the OS passing the KEYUNPRESS signal to Virtual Desktop AFTER the Universal Menu has been invoked, or Virtual Desktop will have to stop listening to that signal or catch the Universal Menu change somehow. I'm not sure which is the appropriate dev path.

 

You are very welcome! Thank you for providing us with additional information. Since you are only experiencing this issue while using Virtual Desktop, it would be best to reach out to the developers of the app here, as they would know how to help with this issue you are having as well as test out a wired mouse to see how it goes. Please don't hesitate to reach out to us again if you have any other questions, and we would be more than happy to continue to help you further! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?