Showing results for 
Search instead for 
Did you mean: 

Bluetooth pairing to iOS is broken

Level 2

Bluetooth pairing seems to be broken for me on iOS. This manifests in a number of issues:

  1. After a factory reset, I cannot complete headset setup on iOS. It spits out an error after I enter my pairing code, exactly the same as in this unsolved issue:
  2. With the device connected to my account (setup through my old Android phone), the device has trouble connecting to my iOS device. In the iOS bluetooth menu, the Quest 2 shows up like it is a bluetooth LE device and never changes (see photo below).
  3. Phone notifications cannot be set up. Trying to set them up causes the "Get Phone Notifications on Your Headset" screen to sit for ~5 minutes, then the process fails and drops back to the previous screen.

Oculus Quest 2 only connecting over bluetooth LEOculus Quest 2 only connecting over bluetooth LE


Community Manager
Community Manager

Hey there! That's not an experience we want to hear from customers. We'd love to help you pair your device to your phone via Bluetooth.


We have a few things we would like to have you try to see if they resolve the issue.

  • Clear the Bluetooth cache and data on the iPhone.
  • Step 1: Open Settings and go to "Apps".
  • Next, go to the Bluetooth option and select it.
  • Step 3: Tap on "Storage" and "Clear Cache"
  • Make the Bluetooth forget the headset and try to pair it.
  • Uninstall and reinstall the Oculus app on the iPhone


Please don't hesitate to reach out to us if you are still having issues. We want to get you back to gaming.


Sorry, I'm not clear on what device you want me to perform those steps on. Due to the way that the device shows up, I cannot unpair it from the iOS bluetooth menu. As for the steps provided:

  1. Open Settings and go to "Apps" -> there is no "Apps" selection in iOS, but there is in the Quest 2
  2. Go to the Bluetooth option and select it -> there is no Apps > Bluetooth option on the Quest 2
  3. Tap on "Storage" and "Clear Cache" -> This option does not seem to be visible anywhere on either device...

I have personally taken a number of steps to try to fix this issue, but none worked:

  • Factory reset the headset again
  • Factory reset the iPhone
  • Unpaired all bluetooth devices from the iPhone, then rebooted
  • Uninstalled the Oculus app from the iPhone, then rebooted
  • Attempted to pair the headset to the iPhone after factory reset
  • Attempted to set up the headset with my old Android device, then pair it to the iPhone
  • Attempted to set up phone notifications through the iPhone after completing pairing with my old Android device
  • Attempted to set up phone notifications on my old Android device, then set up phone notifications on the iPhone

Other notable info:

  • The Quest 2 only shows up in the bluetooth menu on the iPhone when the app is open. Usually it is absent.

Level 3

Same issue during initial setup of Quest 2.

Level 2

I am having the same issue with my refurbished quest 2. I’ve done everything that @Ovrtaker has done and still nothing. 

I paid for a new quest 2 and the fan broke 2 weeks after I got it. I was told I can have a refurbished one which is ridiculous considering I paid full price for a new one. Now, weeks later, I can’t get mine to connect. 

Where is the support? 

disclosure. There’s no apps>Bluetooth in iOS in the settings menu. The support team member has zero clue on how to fix this issue. 


Hey there again. Thank you for letting us know you did all of that troubleshooting.


We have let our engineers know about this issue with the iPhone not connecting and they are working hard to find a resolution.


Can you please try the following as a work around:

  • Can you sign out of all of your Meta/Facebook/Quest accounts via the apps and your browser.
  • Completely power down the headset and your phone, for at least 30 seconds.
  • Power everything back on and sign in to only your Meta Quest account account via phone then headset.

Level 2

Same problem here too, except with an original Quest NOT a Quest 2.  Have tried all suggested fixes with no success. 

Did you ever find a work around? im on the original quest as well. I have gone through countless troubleshooting options to narrow in on a possible solution. I have factory reset a few times, cleared my bluetooth cache, tried to pair on 4 different phones. Attemped to connect via multiple networks, and yet here I am. After searching through pages of reddit feeds and different forums, it seems as if this is a major common issue that "Meta" cant fix. There responses are all the same.

I have the same issue and have not been able to use my Oculus Quest for months. Can someone from Support contact me?

Hey there @Venger_ATX! We noticed that you are having some issues with pairing your device via Bluetooth. We hate to hear that any of our users would be experiencing something like this and we'd love to help you get this sorted out! Can you please provide us with the troubleshooting steps that you have already tried as we don't want to rehash anything for you. Also, are you receiving any error messages when trying to pair your device? We'll be standing by in order to offer further assistance!