cancel
Showing results for 
Search instead for 
Did you mean: 

Brand New 2022 Dell G15 Special Edition Will Not Link To Meta Quest 2

dannylee11
Explorer

OK so i just purchased a brand new 2022 Dell G15 5521 Special Edition Laptop that has the following specs:

 

12 Gen I7-12700H

Windows 11

32Gigs DDR5 Memory

3 USB 3.2 Gen 1 Ports

1 USB 3.2 Gen 2 Type C Ports w/ Display Port

RTX 3070 TI Graphics Card

 

I'm attempting to PC Link to my Meta Quest 2, and the Oculus Desktop Software is not seeing that my Quest 2 is Plugged in. It's very frustrating.

 

I know it's not the cable, as I had successfully linked my Meta Quest 2 to my much older, less capable laptop without any issues.

 

I even tried both my USB & Type C ports with no avail.

 

The software just sits there and never recognizes that the Quest 2 is plugged in. I've tried restarting the Quest 2 multiple times, and like i said, I even tried different cable types and ports.

 

It sucks because I got this laptop specifically so I could PC link and have a better experience.

 

Could someone please tell me what im doing wrong?

23 REPLIES 23

If you're having trouble with Oculus Link we can offer some steps to try and remedy this:

 

- What kind of Link cable are you using? We recommend using the official Link cable for the best performance.

- Do you know if your PC meets Oculus Link requirements? Check here if not sure 👉🏻Oculus Link compatibility.

- Make sure to be running the latest stable version of Windows 10, Windows 11 is currently not supported to run Link.

 

Need further help after reviewing these things? Reach out to our expert support team by submitting a ticket here.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Yes, maybe you did not read the full post.  My gaming laptop is over-qualified to run VR, my specs are on my first post.

The cable i am using is a highly regarded Oculus Quest 2 compatible cable bought on amazon (5 star review), and works on my wife's laptop for VR.

The desktop software, just on my new computer, never sees my oculus quest 2 when it's plugged in.  The air link works, but im not wanting air link as it's very laggy.  The whole reason I bought this laptop was specifically so I could hardwire my quest 2.  So you can imagine after spending over $2000 on a computer for VR gaming, only to find that it will not detect my VR headset, is very frustrating.

I feel very strongly that this is not an issue with Windows version, as most people I see out there never seem to have the same issue im having regardless of their windows version, even 11... something else is seemingly going on.

MikeyThai561
Honored Guest

Its the usb drivers. Mine used to work and I was getting 3.2Mbs with my cheap cable and then there was an update I think it was dell? There was a bios update too. And now it only sees it all my usb as 2. I can still get 866mhz with Wifi5 but that tends to stutter sometimes.

Now to find those older drivers? In the device manager, I see all windows default drivers and rollback is greyed out?!?!

 

 

MikeyThai561
Honored Guest

and again...

Dell G15 5515 Ryzen Edition

Ryzen7 5800H 16g

RTX3060 6g

1XUSB 3.1 1xUSB C 2XUSB 2

 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?