cancel
Showing results for 
Search instead for 
Did you mean: 

Can an Oculus Business version headset be converted to a Consumer version?

havenocat3
Explorer

My school has a set of 15 brand new Oculus 2 Business devices that are in operable because there is no apps or app store on them, and now they are no longer supported. Since they have exactly the same hardware as a consumer version, is it possible to install the Consumer OS to convert it?  How would we do that? 

 

Here is what is displayed in the Business Version Headset

Business Oculus in About in ADMIN view (seen from inside headset)

Version 29.0.0.309.370.346330959

Runtime version 29.0.0.319.370.348573960

OS version user-24721951100100000

 

We have a consumer headset and this is what is displayed regarding the OS (seen from inside headset)

Software Update System Version 373144008900000 (no updates available)

Version 43.0.0.178.120.389405224

Runtime Version 43.0.0.178.120.389406401

OS version user-37314400808900000

22 REPLIES 22

Hi, your screenshot shows that you tried to sideload the adb-zip but you had to sideload the firmware-zip from the link i`ve posted instead!

 

Great it works now! 🙂

Hey Can,

Wondering if you can help me out too.

Similar issue, got an oculus for business and trying to load consumer onto it.

I have ADB and an update file. Plugged oculus into a usb 3.0 port on my computer, go to sideload (oculus does nothing), but ADB can't see it. I dont have any devices in my ADB Devices list.

TranquilJam_0-1670135979941.png

Hi. When I sideload the zip file that you said to download the headset only seems to download 50 % of the files. It also says that only 1 file was transferred when I believe there should be 2 files. What am I doing wrong? Would you be able to give me some advice? Thanks. 

Hi. I have tried the same procedure as you and i am able to upload to software, however, it only gets to about 50% then it stops. It then says it transferred 1 file. I think you said it transferred 0.05 files when you first carried out the side load. How did you correct this so it downloaded correctly (2 files). If you could be of any help that would be great! Thanks 

I tried this multiple times on my Quest 2 and it still boots into Business Edition. 

 

when I run the adb sideload, it starts the transfer and gets to about 50% and then that line goes away and I see "Total xfer: 1.00x"

the headset boots back into business edition like nothing happened.  Capture.PNG

I am going to keep trying and hoping it will eventually just work. 

Nevermind, I contacted BE support and here is what they had to say:

 

" OFB headsets are specially configured on our servers and can only be updated to the current Enterprise OS version which is v29. If a headset has an OS version higher than V29 it cannot be converted back to the Enterprise OS. In order to protect the headset it is blocked from being updated past v29 so that it can go back to the Enterprise OS when needed. This is why your headset will not update past v29 of the Consumer OS. "

current versions of Business Edition headsets cannot be sideloaded this way. They did offer to wipe them remotely for me 

Just got a reply from Oculus Business Support. In my case. the headsets up "up to date" for BE headsets, and the latest version does not allow them to be updated past that version. Contact support and they should be able to help if you can find your serial number. 

Hi I have the same issue with sideloading not working. Was support able to change the headset over to consumer and the latest version. I contacted normal meta support and they were no help. If they did help fix it  could could you link the support here. 

https://oculusforbusiness.zendesk.com/hc/en-us/requests/new

this is the page to contact business support. You can also access it from the device management console 
https://my.workplace.com/device_management/

MR.Rustam
Honored Guest

Even if you change the firmware to personal, you will have an application store, but you will not be able to add more than one account.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?