Showing results for 
Search instead for 
Did you mean: 

Can not install Oculusetup.exe.

Level 2

As i said, i cant install Oculus PC App. I've deleted all the directories and tried again. It goes the the downloading part but when it gets to the installing part it reaches the end then fails and tells me to restart my computer. And I have, many many times. I've tried everything i've seen on the internet it seems. Anyone have any fix or workaround for this?


Community Manager
Community Manager

Hey there! Installing issues? Yikes. This is not what we want you to experience at all! Due to the limited number of tools we have for these issues, we will need to direct you to our Meta Store Support.


You can either submit a ticket, get on a live chat, or even schedule a phone call. You can get in contact with one of our extraordinary agents.



This can happen by clicking here

Level 2

Did that and you guys haven't helped me.

Yikes! This is certainly not the experience we want you to have at all! No worries, we are here to help in the meantime. 


Please select our name to get to our profile page, or click here: Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.


Also, we will provide you with a link that has our PC requirements which you can look over to double check for now.


We will be patiently waiting for your message! 

Level 3

The Restart message has many triggers, which is why there are so many suggestions for how to fix it.


Read toward the end of %localappdata%\oculus\oculussetup.log and find out what kind of problem setup is having. Then you'll know what you're trying to fix.