Showing results for 
Search instead for 
Did you mean: 

Can't install Meta Quest+ games of March 2024

I have my Meta Quest+ subscription active, i can download and play Contractors and Shadow Point.
But I'm unable to download the other games included this month:
Espire 1: VR Operative
Fruit Ninja
Hand Physics Lab
Jurassic World: Aftermath
Red Matter
Sports Scramble
The Climb
Township Tale
Until You Fall
Walkabout Mini Golf
I was on my Meta Store app using my Quest 3, and i clicked the button "redeem". The button now is greyed out, with all the games, but i can't see any further options like: "Download" or "Install".
Seems to be stuck!!
Also tried the same using my Meta Android app, and the same... stuck without any option to "Download" or "Install".
EDIT: @FunkyTanuki requested the Runtime Version, mine is v62

Accepted Solutions

Meta Quest Support
Meta Quest Support

Hey everyone, I've got some good news. Just got word that this should be fixed in a few hours. I recommend checking once an hour to make sure you catch the fix once it goes live. Let me know when it reaches you, I'd really appreciate it. Thank you for your patience while this issue is getting resolved.

"I Have Found That People Lie, Most Often Deceiving Themselves. Not So The Dead. The Dead Are So Very, Very Loud. And Yet, Lying Is Not In Their Nature. It Is So... Humbling, To Listen To The Dead Speak."

View solution in original post



Thanks for posting as I'm having the exact same issue.

I reckon they ran out of licences from developers as everyone rushed to download new free contents.

Slightly gutted as I only paid for Red Matter 1 last week!


I also have the same issue. 
I purchased the quest+ subscription for these games and I can't play???


Hello, I'm in the same situation.

I can download some games, but they're limited to 20/30 minutes because I downloaded the demo trial some time ago.


I did Claim the Espire 1 Quest + Game. 

But it wont Show up in the Libary and i can't install it with the quest App.

Device: Quest 2

(I also tried to claim another game and had the same problem)

Same problem. Just got Quest+ and tried to install games from this month's catalog. I can redeem them, but cannot install ANY of them.


Exact same issue. Was able to download and install last months games without issue. Now, none of games from this month are installing on the headset at all. App shows I've redeem and will go to install queue then just reset itself to "install on device" and start the loop all over again. Was really excited for the changes to the plus subscription but this doesn't look promising.


At least I'm not the only one... Keep making noise and Meta will fix this sooner.

Thanks for the Replys and Kudos 🙂

Honored Guest

A friend of mine is having same issue, bumped out, had been looking forward to some co-op VR this evening @Metaquestsupport


I am having the exact same issue on my quest 2, unable to download the extra free games that are available this month. No option for download, just says redeemed and the option is greyed out.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?