Showing results for 
Search instead for 
Did you mean: 

Can't pair my refurbished oculus quest 2 (256 ) with my iphone or an android tablet

Level 2

My oculus headset quit working. I loved my headset and  and I was delighted with the speed of the response and the replacement time when I contacted support.  Then I tried to pair it with the iphone app.  I had no difficulty doing this with my first headset.  It will not pair.  The bluetooth can find it in settings but the app can't, not even with the five digit number.  I researched, contacted support twice, still no luck.  After four days of trying I got an android tablet thinking that might work...again, the bluetooth can find the headset but the app won't pair.  It seems to me that I read that the app was fixed for android devices.  Does anyone have a solution?


Community Manager
Community Manager

Hey there! We hate that you are going through this. We'd love to help you get back to gaming.


Can you please try the following?

  • Log off of all devices.
  • Uninstall the Oculus app from the phone and reinstall it.
  • Go to on your mobile or desktop app and log out.
  • Next, log in with the Facebook or Oculus account you used to set up your headset or Meta account you made.

Please don't hesitate to reach out to us should you still need help.

Level 2

Apparently it’s a “known issue” based on two separate chat exchanges with tech support. Dev team looking at it, but no known solution or timescales. Catastrophic as can’t use it without this working as far as I can tell

Tried that guide above and still comes back with “unable to connect to your headset”. Known bug and no solution


My original oculus quest 2, developed a fault, where the battery was not holding its charge, 85%, 81%, 79%, 75%, 71%, 68% - over 24hrs

After contacting the Support team, they agreed it had developed a fault and I returned it back for an RMA replacement. This replacement arrived with me on Thursday. However, whilst I have been able to delete my original headset from my account, I am unable to pair the refurbished unit.
I have been trying now for two days. I had a support call with your technical team who advised me that this is an ongoing issue and developing situation which the engineers are working on and has been going on several weeks. I have tried to use an apple, iPhone, and iPad, and even a Samsung galaxy android phone.
My account was credited with £30 due to the inconvenience and compensation to buy Software or games - luckily I still have my quest one which is still registered and working 100% perfectly.
However, at present I am unable to pair my refurbished quest 2 headset with my account, when I asked the technical team if they could automatically add it from their side, I was told that this was not possible and it would only work if I logged into the app and added the device here. I have tried everything including deleting the app, wiping the headset– which was already wiped, switching Bluetooth on and off, deleting the app and reinstalling it, logging in and out my account nothing has worked.

It would make more sense if a link was sent to those affected customers, which they can click on, which prompts them for the Bluetooth code, which then automatically added to their account. This would then allow a workaround solution until the software and hardware is fixed.

From what I understand, this has been going on for several weeks, so I have no idea how this is affecting new customers who are buying a brand-new machine, certainly Meta need to get on top of this and issue a workaround as a temporary measure until the hardware problem can be fixed.

These steps doesn’t work and has been already identified by your support team as being a developing ongoing situation. I have tried every option suggested by your support team and your help emails in the forums and nothing works.
All the users in this forum thread are experiencing the same problem and there is no solution. All I have received so far is a £30 voucher.
I think Meta need to either add individual users devices to their accounts manually either via chat or phone chat using the serial number or send a personalised link to the individual customer so they can register it themselves.

I had a working quest two with a faulty battery now I have a working quest which I can’t use!! 
it makes a very interesting showpiece, and I look at it every day and wish that it worked!

Didn’t work.

Hey there! Oh-uh, this is not the experience we want you to have at all! We can assure you our High Tech Team is working hard to get the solution. 


We know how precious game-time is and we appreciate your understanding and patience.


In the meantime, we can stay updated through our forums or even our website! 


Once we get the information, we will reach back to our lovely community.