Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android


I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

133 REPLIES 133




Firstly, I've just been looking through reddit together with the Oculus/Meta Forums and pages. It seems a common problem since LAST WEEK?!?

Problem: I have just received my refurbished Quest 2 (64GB) and have tried pairing it to my phone as I cannot setup the controllers I had with the last headset without it. My phone says that it is unable to connect to the headset. Therefore, my headset is stuck on the pairing of the controllers screen. 

What I've tried:

  1. Updated my phone,

  2. Updated the Meta App,

  3. Factory Reset on the headset,

  4. Cleared the bluetooth cache ,

  5. Cleared bluetooth data and started again,

  6. Uninstalled and reinstalled the Meta App (Oculus Quest) from my phone.

I thought about USB update via developer mode... but this isn't enabled on my current headset and can't be activated unless I can get into the settings. Nothing has worked! HELP!

I literally have the exact same issue. Won’t connect to the headset. Tried 3 different phones even. Nothing! Going out of my mind! 

Apparently meta sent out a bunch of faulty headsets. Happening to tons of people, including myself. Very disappointing 

Also literally the same issue.

Is that the issue? Would it be worth opening a Support Ticket to ask to a replacement for my replacement...? Seems a bit redundant but if that's what it takes then so be it.

@DominatorVIP Well, it's probably not that they sent out faulty headsets. It's more likely the software update/Meta account change since that has been the root cause for most issues that are going on.

Sometimes it's okay to be a little Bing Chilling

Having the exact same issue currently, contacted customer support and they said that their servers are down so you can't connect your device, but they did not give me any other information.

How long do we have to wait in order to fix it?

Well, just received my replacement, same issue. Support agent was of zero help, of course.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?