Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android

Level 4

I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

132 REPLIES 132

Level 4

Here's how I fixed it:

  1. Download the latest firmware file

  2. Rename it

  3. Power off your Quest 2

  4. Hold Volume - and power until the device boots into a bootloader screen

  5. Using the Volume buttons, navigate to "Sideload Update" and then press power

  6. Connect your Q2 to your PC via the USB-C cable. Use the cable which came with the Q2 if possible

  7. Install the Android Debug Bridge (adb)

  8. Move the file to the same folder as adb
  9. Run adb devices, you should see something like List of devices attached: 123456789 sideload

  10. Run adb sideload

  11. After a few minutes the file will have transferred and your Q2 will begin updating

  12. Once updated, you should be able to pair the app with the handset

If that doesn't work, ask Meta for a refund of their crappy product!

Level 3

Thank you so much, Terence!!

Did it worked with the replaced quest 2?

Yes, I have followed the steps from Terence and it worked! 


When running the ADB devices through command prompt or powershell: make sure the is in the same folder as the platform-tools... And I used /adb. devices to launch it. 


If in doubt... Type adb into cmd prompt and then press tab

What is the solution to this issue please? Your edited post now says Solved but I can't see the solution.

The 'SOLVED' is actually a link for you to click, else go to:


For the solution. Good luck. 

Any idea how to do a fix with Mac and iPhone?  I'm on my second refurbished exchange and I'm hoping a fix like this will solve the problem.  I'm stuck at the pairing the controllers and can't connect to phone to try to pair with the app.  Is it even possible to get a refund?  Support doesn't seem willing and there's no actual customer service department.  My Quest 2 stopped working after 3 months.

Hi Jonkson,

Have you tried installing adb for mac?

That should allow you to sideload the update.

Frankly, if your device doesn't work, you should return it for a refund. If they won't accept that, ask your payment provider to do a chargeback.

Good luck 

@TerenceEden I'm fairly new to vr, this sounds quite complicated to me unfortunately, do you know of a how to video anywhere? Cheers