Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android


I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

133 REPLIES 133

Thank you!!! It helped!

That helps, thanks for the link.  I didn't even know what to look for.  I literally have been without a working headset since August 8 and gone back and forth with support over two refurbished headsets they exchanged and both didn't work out of the box.  I've been trying the last week to get a refund but they keep telling me to take videos to send them so they can see what's wrong.  They already tried one fix, that didn't work, because I don't think I'm even connected to WiFi or bluetooth at all.  Pretty sure they don't want to refund me, and pretty sure their next  "fix" won't work.  I hope I can get in and make it work this way.  Then I'll at least have a working head set.  I'm also considering just doing a notice of dispute to see if that won't make them give me a refund.  Honestly,  time is money and I've already spent more than $300 worth of my time trying to fix this.  It's ridiculous.  Anyway thanks for the help and letting me vent!

Thank you terence Eden you are my hero . I have received my second refurbished headset with the same pairing bug and I decided to follow your tutorial. It worked perfectly. I can't believe META doesn't update the headset before sending them to their customers.  I did it in 5 min because I'm used to rooting android devices but It's not so easy for a noob.

Glad to have helped Floksha! Meta really ought to update headsets - but they should also make sure their apps support older headsets.

How did you get your PC to recognize the headset if the 'yeah sure mate, access me' dialogue popup when you plug in the USB-C never appears? I've got ADB installed and the headset in the blank black space following the meta logo after you select 'sideload update' but nothing appears on the headset.

When I run ./adb devices in the powershell, it just says 'List of devices attached with nothing under it.

I've used this USB port when I was modding my last headset, so I don't think the port is the problem.

Hi there! We would to assist you with this! At this time, we would like for you to reach out to our support team here so we can provide further assistance.



If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


How did you manage to fix the controllers?

You need to follow the instructions. Power off your device, hold Volume Down and power, then select sideload in the headset. adb will then detect it.

hi Aulain , easy, when the headset is paired just go in the app in the device part you have a special section that will guide you to pair your controllers back to the headset.

Hi TerenceEden, I have the same problem, RMA returned device, can't pair to my Iphone to set it up, so nothing works. I am going to try the PC/sideload update you describe. I have a Win10 PC and an Iphone, do I need the ADB app? I am not connecting to an Android phone, or is the QUEST 2 running Android? 

Thanks Karl