Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android

Level 4

I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

132 REPLIES 132

The Quest 2 runs android.


You need to install adb onto your windows PC.


Follow all the steps in order. Once your device is upgraded, it should connect to your iPhone.


If not, call Meta and ask for an upgraded replacement.


I came across this problem. I got to step 9. I have the in my downloads folder. Is there anywhere I need to put the .zip or am I doing something wrong?

You need the zip file in the same folder as adb.


Right, I've done this, restarted cmd and I don't know what the problem is

So, I switched to my laptop and used a straight USB-C to USB-C cord (same one that came with the headset) and it recognized the headset.  I ran "./adb sideload" (I had the file in the same directory as the ABD0

)update adb.PNG


The powershell window indicated that it was loading until it hit 47 or 48% before saying "Total xfer 1.00x", which I understand through some searching is not a failure but rather a quirk of the software.


Then the device makes a boot noise, but nothing happens and it seems to go back to the 'pair controller' screen.

Thanks Terence, I did exactly as you indicated and it worked, I updated the firmware and could pair my headset and finish the setup. It really looks like a firmware version problem. I am glad I found your post!

Level 2

How do you do this on a mac


What address did you get your update file from? I'm concerned mine isn't the right one.  Also, did you simply have to run the sideload update.exe command and the update ran itself or is there a step I'm missing?

I went through the directions, and it failed. I uninstalled the app from my mobile device and powered the headset off for the night. I got up the following day, reinstalled the app, and then turned the headset back on. It was still unable to connect. As I was taking the headset off in defeat, the app said, "Connected." It worked. The solution worked. Thank you, Monk7, for finding the answer, and thanks to Terence for the walk-through.

On a side note, the "customer support" person said their engineers were working on it, and they'll let us know when it is resolved. I can only imagine the amount of bricked headsets out there. They will not look good in sales if this news comes to light. I am a programmer, and something of this magnitude would be all hands on deck and resolved within 24 hours, or start looking for a new job.

Thank you so much!! Your method worked!