Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android


I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

132 REPLIES 132

Wilde_Oscar, the firmware link can be found under a link in the second message on p1 of the thread. 



I really wish I could do this. I know absolutely nothing about this stuff and my son would love his oculus back. Just got off the phone with support and they said everyone who got a refurbished headset recently is having the same issue and they need a few more days to fix their firmware. I let them have it because this is awful customer service. They are going to owe a lot of people new headsets! Unbelievable that they could mess this up so horribly. 

I appreciate the solution, but customers really should not be forced to download software updates off Google Drive in order to get their tech working.


@MetaQuestSupport what measures are you taking to resolve this problem? Do you have a timeframe?


@MetaQuestSupport can you expand on what @SupremeMeme1629 has said here? Can you give us a timeframe?

The issue is some of us can't do that side load fix bc we don't know the first thing about any of it. I'm the furthest from a tech person there is. So the fix ppl found isn't an option for us. Support has said they need some time to figure it out timeline. They have no other information other than "sorry you have a paperweight, we are working on a fix". They need to be working on shipping out the NEW headsets or refunds to all of us. Worst company response ever. 

Nope. Support told me it every refurbished headset. They didn't update them. He told me it is literally a paperweight and he's "sorry". 

I was told they need several days and maybe more bc there is no timeline. "Just be patient" he said. Hope they know this could ruin them if they don't fix it or make it right ASAP

Hi SupremeMeme1629. I have written step-by-step instructions at - lots of people have been able to follow them. I am confident that you will be able to. Best of luck.

I appreciate it. I've seen it and sent it to a friend who may understand it. I have Zero computer knowledge and this means nothing to me unfortunately. Hopefully he will be able to do this for us