Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android


I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

133 REPLIES 133

I've followed the directions exactly, but am running into the same problem as Frugu. When I hit step 10 I get "adb: failed to stat file No such file or directory. Is there something else I need to be doing, or are we just anomolies?


Hey murdrrdbypirates, 

I appreciate the attempt to help. I have been running the command from the correct folder as far as I know. The adb folder in which I have placed the file. I have no problem getting to step 10, and it is showing my device, but I can't seem to get past that point.

I guess I'll be waiting until these guys get their act together, or maybe head out and start looking for pennies to pick up from the sidewalk since it's looking like I could save up for a new quest 2 that way before they actually get this fixed.

Thank you so much, you are a legend! I have been stuck on this issue for nearly three weeks now and I can finally use my Quest 2 again!

Honored Guest

in powershell 
PS C:\adb> adb sideload
loading: ''
* cannot read '' * I can't figure this out 

Hi there! We're glad to hear that this issue was resolved! We'd like wish you happy gaming!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Is this a serious comment? How is downloading an unverified firmware update from a random Google Drive and sideloading it  to the Quest 2 a resolution?

@Ryanality could somebody please take a proper look into this.

Hi there! We would to assist you with this! At this time, we would life for you to reach out to our support team here for further assistance. 



If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I've already spoken to support about this quite a few times now, and the only help I have been offered is "This is an ongoing issue and our engineers are working on it." I'm just being told to wait for an unspecified amount of time.

Same here. No ETA for a fix and sorry "we gave you a paperweight" and "Nothing we can do, please be patient' ...

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?