Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android

Level 4

I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

132 REPLIES 132

oh i got u rename to just update and then in the command put .\adb sideload

Yup, it was something simple that I was missing. Thanks so much, @T0KAA. Everything is paired up, and I'm currently downloading my apps. 


I'm grateful to everyone that helped come up with this fix and explain it to those of us who are barely above computer-illiterate, but seriously disappointed that the company that actually made the headset has done nothing to resolve the problem. Sending out something that you know doesn't work as a replacement for faulty equipment is shady at best. Just be honest about what is going on, and while people may not be happy about it they are at least more likely to be forgiving. As it is now, any time I have the smallest problem with my quest 2 I'll be wondering if I'll have to send it back and how much I'm going to be lied to about the problem being fixed. Several of your customers have no trust in you at this point. I expect that since we are in the minority you don't really care, despite how this is going to affect your bottom line as it becomes more common knowledge, but I hope you'll do something to try to build that trust back up.

Level 4

I tried chat and got disconnected each time I mentioned the issue. Finally got one to stay on the chat and he fix was to pair through the mobile app, as if that's not been tried 1000 times. She said no refunds can be issued bc it is beyond 30 days and that all refurbished headsets are strictly tested. She's nice but clearly has no clue what going on. I can't get anywhere with them. I want a NEW HEADSET or a refund. Now. 

This is the same thing that’s happening to hundreds of people , And we’re told the engineers are Working on a fix! This is such bull**bleep**

Something WTF

THANK YOU!!!!! I spent HOURS on this, and that ONE thing fixed it!


  1. The fix outlined by TerenceEden also worked for me. In my case, I have a Quest-1 and hadn't used it in over a year. When I fired it up it said something about my account changing and needing to go through re-authorizing with the app. When the app finally connected, it gave me the option of a factory reset, which I did. After that, the Quest booted up into a screen showing the 5 numbers to pair with. The App could never connect, multiple factory resets, reboots, etc. 

    The solution for me was: 

    1. install adb on my iMac (google adb for Mac)
    2. download a good update for Quest 1 here:
    3. Follow TerenceEden's steps 2 - 12.

    I had to try several versions before the one above worked. The total time to download the update to the headset using adb was about 5 minutes. The app will count up the % finished in the terminal session up to close to 100%. If it finishes after 50% and says "Total xfer: 1.00x" it didn't take. When it went to 95+% it ended with the message "Total xfer: 2.00x".


Level 3

Do you NEED a link cable specifically? I've used sidequest and pcvr games using other high quality cables just fine.

I have two headsets, my old one and my new one. Throughout this ordeal they have both been reset numerous times. I bought the second headset refurbished for a **bleep** good price, stand alone no box no peripherals because I have everything from the first headset but the lenses are scratched. 

After numerous attempts, it seems my controller and phone only want to talk to the original headset. Despite being reset to the same factory settings, the original can pair to the phone, then the controllers, then wifi and update. But the NEW headset requires an update to pair to my phone and my pc won't pick it up, idk. I guess I still have the original but I don't understand why the refurbished headset cant pair to the app from the same factory reset. Since I unpaired the controllers from the original headset in the app before factory resetting it, I was scared I'd be locked out of the original quest as well but that one can pair to my phone after a factory reset every time. This is really strange, I only spent 120$ on my replacement so I'm not as down and out as many others are but I'm really confused, I would love to make my shiny new headset work

Stupid mistake.  I found out the full file name was

Figured it out!