Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android

Level 4

I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

132 REPLIES 132

Forgive me, but that is a distinction without a difference. Yes, the software needed to be upgraded and because this obvious step wasn't taken, the headset is dead.  They have had this issue for weeks. I sent in a WORKING headset that wasn't charging to 100%. I just want that headset back. I fear this is never going to be resolved and I'm not techie enough to start downloading firmware onto my IOS mac.


I took mine and to a more techie friend and gave him the fix posted here. He got it going after some struggle with what I believe was needing to go "the back way instead of power shell". Didn't understand that but after he figured that out he got it going right away. 

If he lives in NYC I will go to him and pay to have this solved. 


KY, sorry. But surely you can find someone in NYC. He said it was fairly simple. 

I follow his instructions as well I type in the commend adb then adb devices it sees my quest then I type adb sideload but then it gets the error adb failed to find file/batch but the file is in the folder I’m starting to think maybe it’s because I’m on windows 11 because I been trying for 3 days so far and I still get the same error 

Level 2

It was a simple oversight for me....try  

Yeah I just try still got the failed to star file no such file or directory error and on the ODH it says my quest is on v32 

Hi there! We would love to assist you with this! At this time, we would like for you to reach out to our support team here so we can look into this for you. 


We look forward to providing further assistance!



Level 2

I have been fighting this crap with Meta support for over a month now.  My first (new) headset died after only 3 months of moderate use during the required "switch to Meta" update.  Got a replacement/refurbished headset that NEVER worked.  Just got my SECOND replacement/refurbished headset - which doesn't work either.  Last night, Meta support gave me the "it's in our system we are working to fix it" song and dance.  This is crap.  I can't get to the factory reset menu.  My headset will boot and give me a pairing pin, but that's all.


Headset will not see my controllers (new batteries installed)


Headset will not pair to my phone, PC, nor tablet (all Android/Windows based) all software and drivers are up to date)


Headset showed error once last night of "bluetooth keeps disconnecting"


Headset will not factory reset, all I get is the Android "no command" error.


I am BEYOND angry.  Crap product and worthless support.  Between the device and programs, I am about $500 into this entirely non-functional paperweight. 


If they can't give me a functional headset NOW, they need to give me a full refund, including the price of the programs I bought that are worthless without a working headset. 

I just fix my headset yesterday after getting it a week ago so try the sideload Method it was confusing at first but it was all a mis typo