Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android

Level 4

I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.


When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!


Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

132 REPLIES 132

I can't use the "sideload" method.  The headset will not give me the menu to do that.  All I get is the Android "no command" error.  

Same here. 
This worked for me and maybe it will work for you. Connect headset to pc or Mac. 
take batteries out of controllers. Open your oculus app. Put batteries back in. See if oculus app properly recognizes PIN number and lets you proceed with downloading connectors. 

I have a problem with the sideloading not working for me for whatever reason after I put .\adb sideload it updates and I get an xfer: 1.00x. When I get on my quest thinking I fixed my headset it still does not pair with my phone. I have the update. zip file in my adb folder and the file is named update because the file before did not work so I am just confused right now. It looked like it updated but it didn't. What am I doing wrong?

I can get it to recognize the device it I can’t get past the adb sideload

it keeps saying it can’t be found. And I have it in the same folder as

Level 3

So Meta is no longer responding to my emails and I'm still left on the pairing page, even though I was able to successfully pair my phone and my headset. The headset doesn't look to be functional and it doesn't seem to be working anytime soon. I spoke to a lawyer friend and they said that I'd need to gather a couple dozen people in order to take Meta to court in order to get a refund since the value of the headset won't be worth the trouble of going to small claims court. I'm looking to see if anyone would be interested to do that option, even if you were able to fix the headset?


I have solved my problem with my Oculus 1 not pairing with my headset and I am going to help whoever who has a Oculus quest 1 headset refurbished with this issue. 

Step 1: You need to download adb

Step 2: download this update

after you have this file rename it Update

Step 3: Extract all of the adb files and do not extract the Update file you have renamed you instead need to drag that update file into the adb folder 

Step 4: After you have the adb file with the update in it you then need cut that file folder go to

windows ssd (C:) and paste that file there

Step 5: Make sure to power off your headset if you have not after it has powered off hold the power button and the minus volume button you should shortly see a weird pop screen showing you factory reset and enable sideload update use the minus or plus volume to go to enable sideload update. Your headset light should be purple. 

Step 6: Plug your headset into your computer either by USB c or USB c adapter

Step 7: You then need to search in your windows at the bottom of the computer and type Command Prompt you then need to click run as administrator and allow it to make changes 

Step 8: Once you have run as administrator on the Command Prompt app you then need to type cd C:\adb it then should allow this command and you should see C:\adb> if you see this type adb sideload you then should see *daemon not running; starting now at tcp:5037 then *daemon started successfully it should now start updating and after it has updated you should see Total xfer: 2.00x this means the update actually updated to your headset. 

Step 9: You can now x out of the command prompt and unplug your headset from the computer and when you put on your headset you should see and screen that looks like a chip with a loading green bar at the bottom of it this means the update is working. You then should be able to pair your Oculus 1 with your phone. 

If this works for you please use my referal code so me and you get $30 to use in the store


Level 2

Since my POS headset will not produce the popup menu for sideloading, none of these fixes work for me. Does anyone else have this issue?  That your headset will NOT factory reset, that you can't get to that manual sideload menu no matter what you try? 

I am guessing you have tried holding down the power and minus volume button at the same time for however long until the menu pops up on the headset? Usually that is how you are supposed to reach that pop up menu thing that allows you to navigate using the volume button and using the power button to select. I had not seen your issue if you had already done that. 

Level 2

Yes, multiple times.  This should be simple, factory reset is not rocket science.  I have had two replacement headsets sent to me under warranty, both refurbished, both entirely inoperable.  Nothing works.  Won't factory reset, won't pair, doesn't see the controllers, my current one gave me an error of "bluetooth keeps disconnecting."  Meta support tells me the problem is on their end, and I need to wait for them to fix it, which is nonsense.  The headset isn't connected to ANYTHING so their "system" isn't communicating with it.   ABSOLUTE GARBAGE PRODUCT, and worthless customer service.