cancel
Showing results for 
Search instead for 
Did you mean: 

Can't set up RMA'd Quest 2. Doesn't detect controllers or pair with Android

TerenceEden
Level 4

I sent off a broken Quest 2 on Tuesday, and the refurbished replacement arrived on Saturday. That's pretty great service!

But now I'm stuck. The Q2 gets to the "remove the tabs from your controllers" screen - but won't detect my controllers.

I've tried:

  • Replacing the batteries in the controllers

  • Leaving the batteries out for 30 minutes

  • Holding down the Oculus button + B

  • Factory resetting the Q2 using Volume Down + Power

Nothing works. And because I can't get past that screen, I can't pair the Android app with the HMD. I've tried:

  • Restarting my phone

  • Uninstalling and reinstalling the app

Nothing works. The Android app asking for the pairing PIN, accepts it, then displays an error message.

 

When I did the RMA, I was told to only send back the HMD - not the controllers. But it seems there's no way to pair a Q2 with controllers which were previously assigned to a different Quest.

Now I'm stuck and Oculus support is suggesting I RMA the controllers!

 

Is there any way to pair the controllers? Or pair my phone with a Quest 2 which hasn't got any controllers?

132 REPLIES 132

Does updatin require develop mode on? mine is off when i connect the HMD

Watermann17
Level 2

SOLUTION
1. Download and instal Meta Quest Developer Hub
2. log in thru quest account or create new account
3. conect your quest 2 (when the quest is on) with computer thru cable and pair it with Meta Quest Developer Hub
4. Meta Quest Developer Hub - want wifi password
5. restart quest 2 thru button (long push power button and select restart)
6. automatically download and install updates
7. in mobile app pair your oculus and select problem with controllers
8. pair new controllers => Voila! Heureka!

maxmaldves
Level 2

SOLUTION FOR QUEST 2 & MAC 

I have solved my problem with my Meta Quest app not pairing with my Quest 2 headset by using a MAC and the original power cable supplied with the headset.  

Step 1: You need to download adb for MAC. Follow ‘How to set up ADB on macOS’ at this link: https://www.xda-developers.com/install-adb-windows-macos-linux/

Step 2: Download the most recent Quest 2 firmware (v43): https://drive.google.com/file/d/1-XwU2uFh1O2MytV2w_kjhrBvoavq6kRy/view  After you have dowloaded this file rename it as Update.

Step 3: Extract all of the adb files and do not extract the Update file you have renamed you instead need to drag that Update file into the adb folder (named 'platform-tools'). 

Step 4: After you have the adb file with the Update in it, you then need cut that file folder (named 'platform-tools') and paste it on your Desktop. 

Step 5: Make sure to power off your headset if you have not, and after it has powered off, hold the power button and the minus volume button on your headset and you should shortly see a pop screen showing you factory reset and enable sideload update. Release the power button and use the minus or plus volume to go to enable sideload update. After that press again the power button. 

Step 6: Plug your headset into your MAC with the power USB C cable supplied with your headset.

Step 7: Search and open the application ‘Terminal’ in your MAC and type cd /Users/[your username]/Desktop/platform-tools/ . Then you need to type ./adb devices to see the list of devices attached, and you should see your headset serial number followed by the word ‘sideload’. Your headset is now ready to download the update from you MAC. 

Step 8:  Type ./adb sideload update.zip and your headset should start to download the file from your MAC. When it will reach about 98% you should see Total xfer: 2.00x . This means the update is fully and successfully downloaded into your headset. In case the process would stop at 47%, and at the end you would see Total xfer: 1.00x, this means that the update can't be processed. This could happen if you don’t download the last full version of the update, but just an amendment of it, such as v46. 

Step 9: You can now unplug your headset from the MAC and when you put on your headset you should see and screen that looks like a chip with a loading green bar at the bottom of it this means the update is working. You then should be able to pair your Quest 2 with your phone or tablet. If you can’t pair yet your headset, delete the Mobile Quest App and download it again or try using a newer model of phone or tablet.