Showing results for 
Search instead for 
Did you mean: 

Cant Login Samsung Gear VR

Level 3

Looked at a bunch of other posts and cant solve this issue. My headset was working fine until today where i was forced to get a using a meta account. Since then all i get is a "Facebook Session Expired" error. I've uninstalled Facebook and Oculus apps and reinstalled, no change. I created a new FB account and Linked it but again when i open the Oculus Gear VR app i get that error, rebooted the device, no change, removed all FB accounts from my device (S9+) and added only the new account, no change. My old Oculus account doesn't work as i get a "No network Connection" error there. WTF is up with Meta forcing users into this crap that is rife with issues. And I cant raise a ticket because there is no support option for Gear VR. And I refuse to buy a $400 headset just on principle...My existing one worked just fine until today.


I recently like 2days ago factory reset the phone and reinstalled gear vr app when i tried login with my oculus account i had no network internet error i fixed it by updating version of facebook app manager and facebook app installer from 55.1.0 to meta app manager and installer 84.0.11 - after that when i tried login again it was working fine and i could login with no problem so make sure your apps are updated to latest version...

Level 2

Same here

I checked it twice. I have the new Updates for meta Support but it does not work for me.

Same issue as before.


But thank you for your try to help me

Several of us have called samsung customer service only to be on the phone for over an hour with no solutions given. The problem isn't with samsung, the problem is we can't connect to the oculus app which is YOUR APP. We keep getting the same "No network connection" error, and samsung can do nothing about. I paid good money to use this product and now I can't because we can't login to oculus, and all you can do is pass the problem off to samsung. I JUST got into VR, (super late) and I bought an oculus, which it turns out I can't even use it 😞 so I bought the samsung vr instead and now I can't use that either??? I'm smoking mad!!!! I paid several hundreds of dollars and still haven't got to experience VR at all. The only VR room I've seen is the one with the message that says I have to sign in to oculus to continue and I CAN'T!!!

Level 3

same issue here. My old Oculus account doesn't work as i get a "No network Connection" error. I created a new meta account, yet I get the same "No network Connection" error with the new account as well. Feels to me as facebook/meta is purposefully disabling the old VR devices, so we are forced to buy their new quest 2 junk. this is going to be one sweet class action lawsuit.

I also sent a PM to the support, will update on the results here.

Hi, you have described the problem so well and there are no better words to repeat that OCULUS application is the real obstacle here to keep us away from virtual reality. Samsung support representatives will keep you busy on the phone with nice and polite words and conclude: " We no longer support Gear VR" but it is true that we keep selling them. 

Level 2

Having exactly the same issue... any news? This is very frustrating...

Let's hope there are some really enthusiastic specialists that will work to find a solution in a short time. We hope ASP.

But let's nod delude ourselves with useless hopes.

If the problem remains as it is today, somebody must take responsibility and say it now.


I sent PM to support today, but have not heard back as of yet. Has anyone heard back yet?