Showing results for 
Search instead for 
Did you mean: 

Cant Login Samsung Gear VR

Level 3

Looked at a bunch of other posts and cant solve this issue. My headset was working fine until today where i was forced to get a using a meta account. Since then all i get is a "Facebook Session Expired" error. I've uninstalled Facebook and Oculus apps and reinstalled, no change. I created a new FB account and Linked it but again when i open the Oculus Gear VR app i get that error, rebooted the device, no change, removed all FB accounts from my device (S9+) and added only the new account, no change. My old Oculus account doesn't work as i get a "No network Connection" error there. WTF is up with Meta forcing users into this crap that is rife with issues. And I cant raise a ticket because there is no support option for Gear VR. And I refuse to buy a $400 headset just on principle...My existing one worked just fine until today.


I got the following from support which wasn't real helpful as the help article in the link suggests you login into your app or headset and log the bug report!!!! the point being I can't login!!! FFS.


"Thank you for getting back to us! It looks like you may be experiencing a bug. This was not intended by design, so we recommend you submit a bug report with this link. It should be fixed by our engineers. Feel free to reach out with any questions or concerns in the future. We hope you have a great day! "

the link the support gave you is not for Gear VR, it is marked as "Report a bug on Meta Quest 2 and Rift S". Let's see if the support comes through in the PMs.

Level 3

this gets even worse.

original issue: "No network connection" error when using old Oculus account. Creating a new Oculus account will still produce "No network connection" error.

Solution 1: Create a new Facebook account and use it to log into Gear VR. the log in sequence is ok until it gets to the part when it asks to create a new Oculus account, if you agree you will get an error saying that Oculus accounts can no longer be created and advising you to go to to create an account.

Soution2: Create a new facebook account, go to and create meta account associated with new facebook account, so far so good. Try to log in to GearVR with the new facebook account and receive a new error: " Facebook session expired". Logging in and out of facebook app does not help, the error persists and does not allow you to log in into GearVR.

Seems like meta has blocked all and every possible way to log into our expensive headset.

Support? Ideas?


Level 2

I fixed the login error by myself, the Facebook account you use must be connected to meta and oculus, you already know this, but it is not enough, you must also connect/set the horizon profile/account


I already linked my facebook account and my meta/oculus account. And I setted up my horizon profile. If I try to login with my facebook account:

"Session expired Error"

If i try to login without Facebook. So the Meta/Oculus Account:

"No Connection Error"


And I mean if you create a meta account you have to create a horizon profile as well in the next step. Dont you?


So why tf is it working for you? xD

Level 3


I'm running into the same problem as well. I've been keeping an old s6 precisely for this. So after trying pretty much everything suggested here or on reddit, I found a two year old topic that addresses precisely this. They say you need have a sim installed whilst setting up VR for the first time or after big updates. Just that once. However, I don't have a SIM that big handy. So who does is more than welcome to try if that fixes the issue.


The reddit user linked a now deprecated support link that said ""To make sure you can download required software updates, your Samsung Android phone needs to be connected to a mobile carrier for it to work with your Samsung Gear VR." - but why"


Someone please try it to see if that works?


Just after wrote my message, they pushed an update on Facebook. I now have:

Facebook: 383.

Meta App Installer: 84.0.11 - this is unchanged

Meta App Manager: 85.0.13's still not working.

Level 3

I still have not heard from support on my PM. will let everyone know when I do.

GearVR is clearly affected and there is no fix at the moment.

Did you actually try with a working SIM, as I suggested above?

  • A lot of Samsung Gear VR owners have already spent hours maybe days searching and hopping (in vain) to resolve different problems, trying to install and uninstall older versions of the necessary apk's but finaly reaching the sad conclussion "nothing is working". Now they are selling their devices untill there are enough innocent and uninformed clients eager to buy a VR set at an incredibile low price.But they will learn a sad lesson about the SAMSUNG GEAR VR- the device is for museums shelves.Enthusiast will keep hopping, probably some day the Gear VR will be "resurected" from the death.Ho knows? Only the futute will say the true.The reality is that you can buy SAMSUNG GEAR VR. sets for a verry low price, and descendind day by day. And there are a lot of offers for Samsung Gear VR on the second hand market because people has lost confidence in Oculus support to solve their problems.Sad but true.I would like to be wrong and the situation to chage.

I did manage to fix it. Check my topic.