cancel
Showing results for 
Search instead for 
Did you mean: 

Cast to phone not working quest 3

ElusiveGoose
Explorer

Hello, since I got my quest 3 in December it's not been able to cast to my phone. 

It can cast to a browser and to a Chromecast but not my phone. 

I've tried factory reset of q3 and redownloaded the app but no luck. It's the same when on a different WiFi connection also. 

 

16 REPLIES 16

MetaQuestSupport
Community Manager
Community Manager

Hi there, @ElusiveGoose! We know running into issues casting can really take the fun out of VR, so we'd be glad to lend a hand with that! To start, we highly suggest making sure your phone itself and your headset are completely up to date, and the correct casting steps were followed. If the issue persists aside from that, please go through the following to help us get a better grasp of what might be the cause:

 

  • Both the headset and the receiving device need to be connected to the same local area network (Generally this just means connected through the same router, though it may be more complex on public or enterprise systems)
  • Best practice is to have the headset connected through 5Ghz, though 2.4Ghz may still work at limited quality
  • When casting to a computer or mobile app, both the headset and the device displaying the cast must be logged into the same account
    • This limits secondary accounts from casting to the mobile app, as a secondary account cannot be connected to an app
  • You may experience issues when casting and recording simultaneously.
  • Try restarting your Wi-Fi router, and testing the issue again.

 

We look forward to hearing from you, so take your time and get back to us when you can!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hey, hey @ElusiveGoose! We're checking in to make sure you were able to get that casting issue fixed, or if you've run into any further trouble with that at all. It's certainly important to make sure your device is functioning as it should, and we want to make sure everything went smoothly for you along the way. Please don't hesitate to reach back out, as we'd love to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey. Thanks for the response. I just managed to test it now, both on 5ghz and 2.4 with the headset and phone and still the same thing happening as in the video link I posted on Reddit and above. 

It works via Chromecast and computer still but not in the app at all. Just says connecting for a second then stops. 

all logged into same account/WiFi network. I also tried at another house and it is the same. Phone is a Google pixel 6 so modern enough that I don't think it should be a problem. Also it was working on this phone with my old quest 2. 

Any other ideas? I can try another factory reset and redownload the app again but I have already done this once. 

Thanks, Tom

 

Hi @ElusiveGoose. We appreciate you giving all that troubleshooting a go and your patience while we try to get this resolved. Instead of trying the factory reset again, let's see about 'reporting a problem' on your mobile app. You can find the steps here. If, after doing this, you still have concerns or questions, feel free to reach out to us in a PM. Again, we thank you for your time. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Just checking in to see if you're still needing assistance! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

ElusiveGoose
Explorer

Hello, yes I have just sent the problem report on the app so I will see what comes from that. Still no luck in casting to the phone app but to a computer still works. Not sure how to fix still at this point. 

ElusiveGoose
Explorer

It seems similar to some other peoples problems 

Link to another Reddit post with a video link of what's happening. 

 

ElusiveGoose
Explorer

When in settings for Bluetooth it seems to be able to connect, but not to stay connected. Always seems to revert to a disconnected state. I have tried removing and adding the pixel 6 again. Which it can do but it seems that it cannot stay in a connected state... 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?