cancel
Showing results for 
Search instead for 
Did you mean: 

Charger

MaggiMoggi
Level 2

I got a oculus Quest 2 yesterday and i was excited, i got everything to work but the charger i got with the oculus quest 2 doesnt even work, i've tried many wall outlets but it still doesnt charge the oculus quest 2, it only works while i have the charger plugged into my running pc.

6 REPLIES 6

MaggiMoggi
Level 2

and it takes soo long to charge

Bendit74
Level 7

Is this a new Quest 2 unit?

Intel i7-7700K, 32GB RAM - nVidia GTX 1070 Amp Edition 8GB GDDR5. Link Cable via powered extension.

WootM4ge
Retired Support

By the sound of it, the charging cable doesn't seem to be the issue considering that it works while plugged into your PC. Have you tried using a different USB Type C wall adapter? Are you using the one that came with the Quest 2? I'm thinking it could be the wall adapter that is the issue here, are you able to test if the wall adapter is able to charge other devices to test this theory? 

 

If the USB type C wall adapter is the issue, then I'd recommend contacting support through a support ticket, you can do so through the link here: https://metaque.st/Support! They'll be able to look into what options are available to you! Hope this helps! 

Super Hot and Onward to work up a sweat, Walkabout Mini Golf for peace of mind, and Beat Saber to hone my focus! With that out of the way... what can I do ya for?!

yes

im using the one that came with the quest 2, but it charges other devices like normal, just not the quest 2

Hey @MaggiMoggi! Seems like there could be something with your headset going on. We'd love to help out. Please use the link here to reach out where we can look at this issue more in-depth!