Showing results for 
Search instead for 
Did you mean: 

Charging Troubles, Quest 2 and Quest Pro

Honored Guest


I've been having some strange charging behavior with my Quest Pro and Quest 2. When in use, the battery will charge and go to 100% as expected when using the PC quick charge feature as well as my battery banks. However, I bought an Anker 45w charger. As well as tried my Samsung 25W charger, and nothing, the battery keeps draining.

The wall chargers are more than enough, and the battery banks don't seem to be anything special (5v 2.6A is the lowest I've seen charge the battery), so I'm a bit stumped. Will wall charger not charge the headsets in use? 


Community Manager
Community Manager

Hey there @XedtheDead. Thank you for bringing this to our attention. We understand how frustrating it can be when your headset doesn't stay charged and you can't fully enjoy your experience. 


Could you please provide more details about the specific issue? 

Is it related to the cable, charging adapter, or the headset itself? 

Are you using the original chargers that came with the headset? 

Have you tried using different wall ports to charge your headset? 


It's worth mentioning that keeping your headset on the charger while in use can help extend its battery life. We also have an article that provides tips on maximizing your battery life. Once we have more information, we'll be able to assist you with troubleshooting steps.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Could you let us know if you're still having this issue @XedtheDead, we just wanted to check in on you! Please feel free to send us a message through PM if you need our assistance at all. Select our name to get to our profile page and click "Send a Message" to privately message us! Remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello!  I've been trying to reply, but every time I want to log in via my Oculus account, it cancels and still has me signed out.  I managed to trick it though by saying that I want to create a new post and then navigating back to here lol.


My issue was not fixed, though I did some more testing.


I do not have the original power brick anymore, but I have a 45w charger from Anker. It is the Anker 313 if you want to look more into the specs. "Output: 5.0V=3.0A / 9.0V=3.0A / 15.0V-3.0A / 20.0V=2.25A (45W Max); PPS: 3.3V-11V=5A / 3.3V-16V=3A / 3.3V-21V=2.25A (45W Max)"

The battery bank that I am using for the most part is from KKCOBVR (from Amazon).

The cable that I tried came with my Samsung Galaxy S22+ Ultra.  Max rating of 20v 3A.

I am able to charge it through my computer using a 3.0 port and Gigabyte USB Turbocharger (for Android QC 3.0). The cable that I'm using for that is 20ft Kuject USB C cable from Amazon.  I tried it in the Oculus PC app and it gets the full green light for data transfer.  I'm not sure what the specs are for power delivery, but it will charge via PC (only with the Gigabyte USB Turbocharger, but not from the Anker 45w wall charger).

It seems to me that there either might be a charging protocol that the Quest won't match with the wall charger, or that for some reason, the cable is not able to support the amperage needed. This is the same story for the Quest 2.  On the wall charger, it will slowly go down.  It will not stay the same or increase.  I did note on that instance, battery level was at 83%, so it also might be that the quests need to be below a certain percentage in order to accept a charging voltage?

Side note, I did have an instance today where I had it plugged into my PC, it was charging, then it charged, but after that, the battery bank and PC charging no longer worked.  The charging icon and sound did not activate.  I turned the unit off and put it back on the dock and then it started charging again. It was the only time that this happened, but I'm wondering if it will happen again, so I am bringing it up now.


Thank you for the help, I deeply appreciate you working with me through this and reading through all of my text lol

Thank you for your reply and for providing all that information, as it is helpful in helping us gain a better understanding of the issue you are facing. Since you mentioned that you are attempting to charge your headset via your PC, we would like to provide you with the following information:

  • Since computers typically provide less power than outlets, they may require more time to charge.
  • When using an adapter, the port type being used may provide even less power than the USB-C port that is typically used for charging and Link cables.
  • Your computer may also stop charging your headset if it is completely powered off.
    • This causes the computer to not recognize that the device is there.
    • This can also happen when your PC enters its own sleep mode.
  • While in use, the headset will typically consume more power than your computer port can provide, which can cause the battery charge to diminish over time.
    • Be sure that the headset is off or in its sleep state to charge.

In regards to charging your headset via a wall outlet, we would ask that you try the following:

  • Plug your headset in to charge for at least 2 hours.
    • Keep an eye on the color of the LED light and if it is solid or flashing during this time.
  • Attempting charging with a different cable, power adapter, and wall outlet.
    • If possible, be sure to test the original charging cable and power bank that came with your device.
  • If using an Elite Strap or any third-party accessories, please remove them before attempting to charge.
  • Attempt to charge the headset after removing the facial interface.
  • Hard Reboot the headset.
    1. Hold down the power button and volume-down button for 30 seconds until you hear the boot-up sound.
    2. If the boot-up sound is not heard, enter the USB Update Mode and select "Boot Device."
  • Factory Reset

If these steps did not help, then please send us a PM so that we can collect some sensitive information to create a support ticket so that our specialist team can continue providing you with additional support. Please remember, you must be signed into the community first to send us a private message. Let us know if you have any further questions or concerns. 



If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi there, we wanted to follow up with you to see if you still need help charging your Quest Pro and Quest 2. Let us know; we are here to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?